Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан круг радиуса R. Определить, поместиться ли правильный треугольник со сторонами а в этом круге. Для программы Pascal.

10-11 класс

Ивкааа 17 мая 2014 г., 9:35:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ден010
17 мая 2014 г., 11:10:36 (9 лет назад)

Program Pr1;
uses crt;
var r:integer;
b,a:real;
Begin
clrscr;
writeln('Введите R и a');
readln(r,a);
b:=sqrt(a-(a/2));
if (b<r) and (a/2<r) then writeln('Поместится')
else writeln('Не поместится');
end.

Ответить

Другие вопросы из категории

перевести 1011010 в десятичную

Читайте также

Задача № 1

Тронувшись с места, автомобиль каждую секунду увеличивает скорость на а км/ч.
На этом участке дороги существует ограничение V км/ч. Выяснить, через сколько полных секунд автомобиль превысит предельно допустимую скорость V?
Задача №2
Даны действительные числа а, b, c. Определить, можно ли построить треугольник со сторонами а, b, c или нет
Язык ПАСКАЛЬ =)

Написать программу на языке Paskal Заданы диаметр круга D и сторона квадрата А. Определить, поместится ли круг в квадрате. Задачу проверить

при

а) D=70, A=36

б) D=8, A=64

Квадрат поместится в круге, если диаметр окружности меньше или равен стороне квадрата. Результат вывести на экран.



Вы находитесь на странице вопроса "Дан круг радиуса R. Определить, поместиться ли правильный треугольник со сторонами а в этом круге. Для программы Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.