Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите:дан массив из N целых элементов. замените четные элементы массива на число 10

5-9 класс

Osssipiron 24 апр. 2014 г., 0:55:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eaglejkee
24 апр. 2014 г., 3:45:54 (10 лет назад)

var
a:array[1..9999] of integer;
n,i:integer;
begin
readln(n);
for i:=1 to n do
begin
readln(a[i]);
if a[i] mad 2 = 0 then a[i]:=10;
end;
for i:=1 to n do
write(a[i],' ');
end.


Надеюсь на Лучший ответ

Ответить

Другие вопросы из категории

Имеется два различных типа носителей информации: носитель типа А – с максимальным объемом записываемой на него информации 30 ГБайт, типа В – 680 МБайт.

Для носителей типа В сделали полные образы (файлы, объем которых строго равен максимальному объему носителя). Вычислите максимальное количество образов носителей типа В, данные которых можно полностью записать на два носителя типа А (образы не могут быть разбиты на части или сжаты). В ответе укажите целое число.

Помогите пожалуйста сделать Д/З по ИКТ

Задания внутри
Сделать только №2,3,5,7

помогите пожалуйстааа

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.



Вы находитесь на странице вопроса "Решите:дан массив из N целых элементов. замените четные элементы массива на число 10", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.