Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Заполните два массива N [1..15] и M [1..15] случайными числами в диапозоне от -15 до 20ю Подсчитайте в каждом ммассиве количество положительных и

5-9 класс

отрицательных значений. Программа должна быть на Pascale, желательно на завтра.

Akmaraljanum 29 сент. 2014 г., 17:35:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Misha37
29 сент. 2014 г., 19:58:31 (9 лет назад)

Program pr;
uses crt;
Var N,M:array[1..15] of integer;
    i,kNp,kMp,kNo,kMo:integer;
Begin
kNp:=0;
kMp:=0;
kNo:=0;
kMo:=0;
Writeln('mas(N)');
for i:=1 to 15 do Begin N[i]:=random(36)-15; Write(N[i],';') end;
Writeln;
Writeln('mas(M)');
for i:=1 to 15 do Begin M[i]:=random(36)-15; Write(M[i],';') end;

for i:=1 to 15 do Begin
                  if N[i]>=0 then kNp:=kNp+1
                             else kNo:=kNo+1;
                  if M[i]>=0 then kMp:=kMp+1
                             else kMo:=kMo+1;
                  end;
Writeln;
Writeln('Кол-во положительных массива N=',kNp);
Writeln('Кол-во отрицательных массива N=',kNo);
Writeln('Кол-во положительных массива M=',kMp);
Writeln('Кол-во отрицательных массива M=',kMo);
readln;
end.

Ответить

Другие вопросы из категории

Пожалуйста,не пишите всякий бред!Не копируйте с интернета ответы.Мне ответ нужен от людей реально знающих информатику и объясните своими словами!Буду

очень сильно благодарна)

1.В чем состоит различие между папками и каталогами?

2.Почему происходит фрагментация файлов?

3.Каковы основные этапы загрузки операционной системы?

Читайте также

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

1)Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все

элементы с четными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.

2) Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все элементы с нечётными значениями в три раза,а элементы с чётными значениями заменяя на 0.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.



Вы находитесь на странице вопроса "Заполните два массива N [1..15] и M [1..15] случайными числами в диапозоне от -15 до 20ю Подсчитайте в каждом ммассиве количество положительных и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.