Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

За один ход с числом делается операция вида: если число не делится на 3,то вычетаем 1 а если делится , то делим на 3.Так из числа 39 единица получается за

5-9 класс

5 таких ходов(имеется в виду цепочка, 39-13-12-4-3-1)
Программа должна:
-Запросить число ходов k(натуральное число,0<=k<=37)
-Найти и вывести на экранНаименьшее натуральное число, которое превращается в единицу за k таких ходов.
Язык программы Pascal АВС.

Alenagomel2 10 марта 2017 г., 11:00:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastiklive5
10 марта 2017 г., 13:42:51 (7 лет назад)

Есть =)
program z;
var k, x, i: integer;
begin
readln(k);
x:=1;
for i:=1 to k do
begin
if ((x + 1) mod 3 = 0) then x:=x*3
else x:=x+1;
end;
writeln(x);
end.

Ответить

Другие вопросы из категории

1. Вычислите, сколько килобайтов содержится в 4096 битах.

2. Вычислить, сколько байтов содержится в одном мегабайте.
3. Вычислите сколько килобайтов содержится в 30720 битах.
4. Одна тетрадь содержит 262144 символов, сколько это в мегабайтах?
5. Можно ли поместить файл размером 0,35 гигабайт на носитель, на котором свободно 365000 килобайт.
ПОМОГИТЕ ПОЖАЛУЙСТА! :(

Читайте также

1) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок

может добавить в кучу 1 или 2 камня или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 17 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 24. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 24 или больше камней.
В начальный момент в куче было S камней, 1 ≤ S ≤ 23.
1. При каких S: 1а) Петя выигрывает первым ходом; 1б) Ваня выигрывает первым ходом?
2. Назовите 2 значения S, при которых Петя может выиграть своим вторым ходом?
3. При каком S Ваня выигрывает своим первым или вторым ходом?

компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С за три месяца, вирус Д за шесть месяцев. На

компьютере одновременно обнаружены сразу все четыре вируса. Сколько гигабайт они заполнят за один месяц?

компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус D

заполняет 1 Гбайт за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса. Сколько гигабайтов они заполнят за один месяц?

Компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за шесть месяцев. На

компьютере одновременно обнаружены сразу все четыре вируса. Сколько гигабайтов они заполнят за один месяц???

Компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус D заполняет

1 Гбайт памяти за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса. Сколько гигабайтов они заполнят за один месяц?



Вы находитесь на странице вопроса "За один ход с числом делается операция вида: если число не делится на 3,то вычетаем 1 а если делится , то делим на 3.Так из числа 39 единица получается за", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.