Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводятся три числа (длины сторон треугольника). Определить, можно ли построить треугольник по введённым сторонам.

5-9 класс

Программа Паскаль

Вита007 10 марта 2014 г., 2:34:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vladislavchiks
10 марта 2014 г., 4:30:18 (10 лет назад)

var a,b,c:integer;
begin
  read(a);
  read(b);
  read(c);
      if (a+b>c) and (a+c>b) and (c+b>a) then
          writeln('Да')
      else
          writeln('Нет');
  readln;
end;

Ответить

Другие вопросы из категории

В финале турнира Российской Армии по шахматам встретились представители шести воинских званий: майор, капитан, лейтенант, старшина, сержант и ефрейтор,

причём разных специальностей: лётчик, танкист, артиллерист, миномётчик, сапёр и связист. Определите специальность и звание каждого из шахматистов по следущим данным:
1) В первом туре лейтенант выиграл у лётчика, майор у танкиста, а сержант у миномётчика;
2) Во втором туре капитан выиграл у танкиста;
3)В третьем туре и четвёртом турах мномётчик из-за болезни не учавствовал в турнире, поэтому свободными от игры оказались капитан и ефрейтор;
4) В четвёртом туре майор выиграл у связиста;
5)Победителями турнира оказались лейтенант и майор, а хуже всех выступил сапёр.

Объясните пожалуйста, как решать такие задания. Исполнитель Чертежник перемещается на коор- динатной плоскости, оставляя след в

виде линии. Чертежник может выполнять команду Сместиться на (a, b) (где a, b — целые числа), перемещаю- щую Чертежника из точки с координатами (x, y) в точку с координатами (x + a, y + b). Если чис- ла a, b положительные, значение соответствующей координаты увеличивается, если отрицательные — уменьшается. Например, если Чертежник находится в точке с координатами (5, 3), то команда Сместиться на (2, –3) переместит Чертежника в точку (7, 0). Запись Повтори k раз Команда 1, Команда 2, Команда 3 конец означает, что последовательность команд Команда 1, Команда 2, Команда 3 повторится k раз.

Чертежнику был дан для исполнения следующий алгоритм:

Повтори 4 раза Сместиться на (2, 0), Сместиться на (0, 3), Сместиться на (–2, –3) конец

Какую фигуру нарисует Чертежник?

1) треугольник

2) квадрат

3) незамкнутую ломаную линию

4) параллелограмм

Решите задачу, используя круги Эйлера. В салоне небольшого самолета летят 42 пассажира. Некоторые из них москвичи,остальные-иногородние.Среди москвичей 9

мужчин.Некоторые из пассажиров
артисты,но ни одна из иногородних женщин не является артисткой.Всего иногородних мужчин 18.Из них 13 - не артисты.Среди пассажиров, не являющихся артистами,16 мужчин и 11 женщин, 6 москвичей не артисты. Разберитесь с пассажирами: кто есть кто?

Укажите ( поставьте знак "+" в нужной графе ), какое программное обеспечение необходимо людям в следующих ситуациях.

Варианты ответов: Системное ПО , Приложения , Системы программирования.
Ситуация 1.Архитектор проектирует внешний вид нового жилого комплекса.
Ситуация 2.Сотрудник банка пишет новое приложение для банковской сети.
Ситуация 3.Фотограф обрабатывает фотографии, полученые в результате съемок видов города.
Ситуация 4.Корреспонденты журнала собирают информицию о прошедшем недавно празднике.
Ситуация 5.Подросток создает сайт для поддержки любимой игры в Интернете.
Ситуация 6.Первоклассник изучает буквы с помощью компьтерной обучающей программы.
Ситуация 7.Продавец в супермаркете заносит данные о купленном товаре.
Ситуация 8.Врач ведет историю болезни вновь поступившего больного в электронной базе данных.
Ситуация 9.Строители нового моста проводят исследования его прочности по созданной на компьютере модели.
Помогите! Очень срочно нужно!

Читайте также

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Написать программу в паскалabc

Даны 3 числа. Определить, можно ли построить треугольник с указанными сторонами.

Вводятся 4 числа. Вывести на экран максимальное

Вводятся три числа. Вывести на экран число с минимальной суммой цифр.

Помогите пожалуйста в Паскале



Вы находитесь на странице вопроса "С клавиатуры вводятся три числа (длины сторон треугольника). Определить, можно ли построить треугольник по введённым сторонам.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.