Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Напишите программу(Паскаль), которая считывает с клавиатуры вещественное число Х и выдает на экран значение выражения 1\Х. Очевидно значение х=0 является

10-11 класс

недопустимым. Для проверки вводимых с клавиатуры данных воспользуйтесь оператором REPEAT :ссс

Jaffa05 18 марта 2014 г., 0:16:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ВИКА473648
18 марта 2014 г., 3:11:58 (10 лет назад)

var
x: real;

begin
readln(x);
if x=0 then exit;
write(1/x);
end.

Не понимаю, зачем тут repeat

+ 0 -
Sergggio
18 марта 2014 г., 5:47:44 (10 лет назад)

ну совсем просто

+ 0 -
Ruskina
18 марта 2014 г., 7:05:07 (10 лет назад)

ну и?

+ 0 -
Gorshenevs
18 марта 2014 г., 9:42:05 (10 лет назад)

Решение готово

Ответить

Другие вопросы из категории

Помогите с решением, спасибо.

1. При подключении к Интернету модем обеспечивает
скорость передачи данных, равную 28

Значения элементов двумерного массива А были равны 0 . Затем значения некоторых элементов были изменены (см. представленный фрагмент программы).

n := 0
for i :=1 to 5 do
for j:=1 to 6-i begin
n := n + 1;
A [ i , j ] :=n;
end;
Какой элемент массива будет иметь в результате максимальное значение?
1)A[ 1 ,1 ] 2)A[ 1 , 5 ] 3)A[ 5, 1 ] 4)A [5 , 5 ]




Читайте также

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.



Вы находитесь на странице вопроса "Напишите программу(Паскаль), которая считывает с клавиатуры вещественное число Х и выдает на экран значение выражения 1\Х. Очевидно значение х=0 является", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.