Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОЖАЛУЙСТА ПОМОГИТЕ!!! даны 2 массива, найти среднее арифметическое 2-х массивов и сравнить чье больше.

10-11 класс

аникарна 09 окт. 2014 г., 18:28:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЧёрныйАнгел97
09 окт. 2014 г., 20:28:22 (9 лет назад)

 var 
  A,B:array[1..100] of integer;
  i,n:integer;
 SRA, SRB:real;
begin
 randomize;
 Readln(N);
 Writeln('Исходные массивы:');
 SRA:=0;
 SRB:=0;
 for i:=1 to n do
  begin
    A[i]:=random(10);
    writeln('A[',i,']=', A[i]);
    SRA:=SRA+A[i];
   end;
  for i:=1 to n do
  begin
    B[i]:=random(10);
    writeln('B[',i,']=', B[i]);
    SRB:=SRB+B[i];
   end;
 SRA:=SRA/n;
 SRB:=SRB/n;
if SRA>SRB then 
 writeln('Средние арифметическое первого массива больше')
 else
  writeln('Средние арифметическое второго массива больше);
end.

 

Ответить

Другие вопросы из категории

Программирование 10 класс. Язык паскаль.

В зависимости от количества введенных лет (от 1 до 20) вывести сообщение типа:
мне 3 года
мне 15 лет
мне 1 год

Помогите, пожалуйста,

решить задачу:

Для
данного x вычислить значение функции, заданной системой:

Помогите упростить выражение

ab!cd+!abc!d+!ab!cd+!abcd+abcd+!ab!cd

Читайте также

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.



Вы находитесь на странице вопроса "ПОЖАЛУЙСТА ПОМОГИТЕ!!! даны 2 массива, найти среднее арифметическое 2-х массивов и сравнить чье больше.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.