Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

даны 2 массива из n элементов.нужно сравнить сумму массивов,вывести на экран если массивы равны,а если не равны, то каком в каком из них сумма больше?

10-11 класс

задачу практически решила,только вот немного запуталась
помогите найти ошибку пожалуйстаа

var a:array of integer;
b:array of integer; i:integer;
s,d,f,n,k:integer;
begin
writeln ('vvedite n');
readln (n);
setlength (a,n);
setlength (b,n);
randomize;
s:=0;d:=0; f:=0; for
for k:=0 to n-1 do
begin
a[i]:=random(100);
b[i]:=random(100);
if a[i]=b[i] then f:=f+1;
end;
if f=n-1 then writeln ('massivy ravny')
else
begin
for k:=0 to n-1 do
begin
s:=s+a[i]; d:=d+b[i]; end;
if s>d then
writeln ('summa bolshe v massive a')
else
writeln ('summa bolshe v massive b');
end;
readln;
end.

Valsan65 03 дек. 2015 г., 2:01:51 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evgenijkosmile
03 дек. 2015 г., 2:52:55 (8 лет назад)

Решение задачи в файле (есть .pas и .txt версии)

Ответить

Другие вопросы из категории

помогите, пожалуйста
2) (В2)Исполнитель

КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера:

Кто знает как это сделать?

Если можно с решением пожалуйста)))

какая из данных пар чисел является решением уравнения (x-1)^+y^=25,решить это надо с помощью EXSEL.Варианты

ответов:(-3;4),(5,3),(-5;-3),(3;-4).Ребят,помогите пожалуйста.

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива

дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0



Вы находитесь на странице вопроса "даны 2 массива из n элементов.нужно сравнить сумму массивов,вывести на экран если массивы равны,а если не равны, то каком в каком из них сумма больше?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.