Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

задано натуральное число N , вычислите сумму цифр числа используя цикл while

5-9 класс

Lorein 01 марта 2016 г., 3:45:15 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vova192009
01 марта 2016 г., 5:50:41 (8 лет назад)

var sum,n:int64;
begin
  write('Vvedite chislo: ');
  readln(n);
   while(n>0) do begin
    sum:=sum+(n mod 10);
    n:=n div 10;
   end;
  writeln(sum);
  readln;
end.

Ответить

Другие вопросы из категории

Читайте также

ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!

Решить задачи на турбопаскале:
1.Дано натуральное число Найти сумму и произведение первых двух чисел.
2.Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.
3.Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

Введите целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10

Составьте программу,которая определяет,является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода:567.
Пример вывода:сумма цифр числа 567-четное число

Ввести целое число и найти сумму его цифр.

Пример:
Введите целое число:
1234
Сумма цифр числа 1234 равна 10.

Ввести целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10



Вы находитесь на странице вопроса "задано натуральное число N , вычислите сумму цифр числа используя цикл while", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.