Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста. Нужно написать программу для PascalABC.NET, которая сможет вычислить сумму огромного количества однозначных чисел. Количество чисел -

5-9 класс

5786.

Mrjack98 02 февр. 2014 г., 23:46:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hak000
03 февр. 2014 г., 1:09:56 (10 лет назад)

const
  n = 5786;

var
  i, s: integer;

begin
  Randomize;
  s := 0;
  for i := 1 to n do s := s + Random(10);
  writeln('Сумма ', n, ' целых чисел [0..9] равна ', s)
end.

Тестовое решение:

Сумма 5786 целых чисел [0..9] равна 25695


+ 0 -
Arinka91
03 февр. 2014 г., 2:16:02 (10 лет назад)

Что значит "огромное количество"? нельзя написать программу на все случаи жизни, всё в реальности имеет ограничения.

+ 0 -
Zulfira9
03 февр. 2014 г., 3:30:28 (10 лет назад)

Кроме самой реальности разумеется...

+ 0 -
частушка
03 февр. 2014 г., 4:33:52 (10 лет назад)

Объявите переменную типа int64 и получите возможность сложить 10^18 однозначных чисел. Если предположить, что за секунду компьютер делает 10 млн сложений, потребуется 78 лет его непрерывной работы, чтобы выполнить все эти сложения.

Ответить

Другие вопросы из категории

Помогите решить задание №51 по информатике 5 класс рабочая тетрадь Босова Л.Задача:Сегодня у Пети и Коли новая игра:Коля задумывает правило преобразования

числовой информации,а Петя должен отгадать это правило. 1 - 1;2 - 2;3 - 0;4 - 1; 20 - 2;21 - 0. 1 - 0;2 - 0;3 - 1;4 - 1;20 - 6;21 - 7.

Срочно решите пожалуйста

Читайте также

СРОЧНО

Ребят, помогите пожалуйста.
Нужно написать программу (или программы) для вычисления суммы, произведения и среднего арифметического для трех чисел.

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)



Вы находитесь на странице вопроса "Помогите пожалуйста. Нужно написать программу для PascalABC.NET, которая сможет вычислить сумму огромного количества однозначных чисел. Количество чисел -", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.