Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

паскаль прошу очень важно)Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа

5-9 класс

получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, кратное 4. Пример работы программы:

Newgar 30 авг. 2015 г., 7:24:57 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Udavaaa
30 авг. 2015 г., 9:17:24 (8 лет назад)

только последовательность обязательно должна заканчиваться 0 и предпоследнюю строчку можешь не писать, она для того чтобы был виден результат, это ГИА да? если да, какой регион?

var ch, max:longint;
begin
max:=0;
readln(ch);
while ch<>0 do begin
if (ch>max) and (ch mod 4=0) then
max:=ch;
readln(ch);
end;
writeln(max);
readln;
end.

+ 0 -
Khanva31
30 авг. 2015 г., 10:27:55 (8 лет назад)

var
a,b,max,i:integer;
begin
read(a);
max:=0;
for i:=1 to a
do
begin
read(b);
if (b mod 4=0) and ((b>max) or (max=0))
then
max:=b;
read(b);
end;
write(max);
end.

Ответить

Другие вопросы из категории

пользуясь дополнительными источниками информации,ответьте на следующие вопросы:

1)Один из языков программирования называется Ада.Каково происхождение этого названия.??
2)каково происхождение названия языка программирования Паскаль???
3)Кто является разработчиком языка программирования Лого???

надо решать через Паскаль. составил две программы и обе со странным ответом. что не то? program qwe; uses crt; var

x.s:integer;

y:real;

begin

s:=0;

for i:= -2 to 27 do

s:=s+x;

y:=s/30

writeln('srednee arifmeticheskoe=',y);

readkey;

end.

program dada;

uses crt;

var i,s,o:integer;

begin clrscr;

s:=0;

o:=0;

for i:=-2 to 27 do

begin s:=s+1;

o:=o+1;

end;

writeln(s/o);

readkey;

end.

Читайте также

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Количество чисел не превышает 1000. Введенные числа не превышают 30 000.
Программа должна вывести одно число - максимальное число, кратное 5.

Напишите программу , которая в последовательности натуральных чисел определяет максимальное число , кратное 5. Программа получает на вход количество

чисел в последовательности , а затем сами числа . В последовательности всегда имеется число , кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число , кратное 5

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество

чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Паскаль

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3. Пример работы программы: Входные данные Выходные данные 3 23 13 23 3

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!



Вы находитесь на странице вопроса "паскаль прошу очень важно)Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.