Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составьте программу [1,,20] случайными целыми числами в диапазоне от 1 до 30 и выводит на экран элементы, значения которых являются чётными и кратными 3

5-9 класс

Androyd 30 июня 2016 г., 20:56:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
СКП
30 июня 2016 г., 22:47:28 (7 лет назад)

uses crt;
const n=20;
var a:array[1..n] of integer;
i:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(30);
write(a[i]:3);
end;
writeln;
for i:=1 to n do
if (a[i] mod 2=0) and (a[i] mod 3=0) then write(a[i]:3);
end.


Ответить

Другие вопросы из категории

Помогите пожалуйста срочно надо

Что означает?
Ctrl+Home
Page Up
Delete
Caps Lock
Esc
Insert
Enter
Ctri+Backspace
САмА Не РаЗбЕрАюСь

надо подписать, пожалуйста!
В соревнованиях по ориентированию участвуют 120 спортсменов. Специальное устройство регистрирует финиш каждого из участников, записывая его номерс

использованием минимально возможного количества битов, одинакового для каждого спортсмена. Каков будет информационный объём сообщения (в байтах), записанного устройством, после того как финишируют 96 спортсменов?

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.



Вы находитесь на странице вопроса "составьте программу [1,,20] случайными целыми числами в диапазоне от 1 до 30 и выводит на экран элементы, значения которых являются чётными и кратными 3", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.