Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Имеютися данные о среднемесячной температуре за год. Определите самую высокую и самую низкую температуры. Сколько месяцев в году было теплых(температура

5-9 класс

выше 0) через массивы

Nast8462 03 окт. 2016 г., 5:50:06 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rebekkah
03 окт. 2016 г., 8:43:33 (7 лет назад)

const N = 12;
const k = 0;
var temp : array [1..N] of integer;
    i, min, max, count : integer;
begin
    min := 1000; max := -1000;
    count := 0;
    {Заполнение массива данными}
    for i := 1 to N do
    begin
        write(i,'-й месяц: ');
        readln(temp[i]);
        if (temp[i] > max) then
            max := temp[i];
        if (temp[i] < min) then
            min := temp[i];
        {Если температура выше k - месяц считается теплым}
        if (temp[i] > k) then
            count := count + 1;
    end;
    writeln('Минимальная температура: ',min);
    writeln('Максимальная температура: ',max);
    writeln('Количество теплых месяцев: ',count);
    readln;
end.

+ 0 -
Nataliakvapak
03 окт. 2016 г., 10:27:03 (7 лет назад)

А данные то где?

Ответить

Другие вопросы из категории

Помогите мне пожалуйста!! Я много проболела и тут учитель по информатике задал тест и подготовку дал 1 день! А я ничего не знаю, совершенно=(((((

1) Сообщение записано буквами из 16 символьного алфавита, содержит 145 символов. Какой объем информации оно несет?
2) Информационное сообщение объемом 2.5 Кбайта содержит 2560 символов. Сколько символов содержит алфавит, при помощи которого было записано это сообщение?
3) Для записи текста использовался 4 - символьный алфавит. Каждая страница содержит 30 строк по 70 символов в строке. Какой объем информации содержат 5 страниц текста?
4) Сообщение занимает 4 страницы по 50 строк. В каждой строке записано по 65 символов. Сколько символов а алфавите, если все сообщение содержит 8125 байтов?
5)Сообщение записано буквами из 64 символьного алфавита содержит 60 символов. Какой объем информации оно имеет?
6) Сколько Кбайт составляет сообщение, содержащее 16384 бит?
7)Информационное сообщение объемом 0.25 Кбайта содержит 1024 символа. Сколько символов содержит алфавит, при помощи которого было записано это сообщение?
8) Для записи текста использовался 256 - символьный алфавит. Каждая страница содержит 30 строк по 70 символов в строке. Какой объем информации содержат 5 страниц текста?
9) Сообщение занимает 6 страниц по 35 строк. В каждой строке записано по 50 символов. Сколько символов в алфавите, если все сообщение содержит 7875 байтов?

Решите уравнение 100(в 5 сс)+x=200(в 4 cc)

Ответ запишите в семеричной системе счисления.

Написать программу Pascal

Оканчивается ли заданное число цифрой 6?

Читайте также

Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот

период. Прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0).

На входе программа получает период N

В таблице Dat хранятся данные измерений среднесуточной температуры за

10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй
и т. д.). Определите, какое число будет напечатано в результате работы
следующей программы. Текст программы приведён на трёх языках
программирования

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его тип

Имеются данные о количестве полных лет трех призеров спартакиады. Напишите программу, выбирающую и выводящую возраст самого младшего призера.



Вы находитесь на странице вопроса "Имеютися данные о среднемесячной температуре за год. Определите самую высокую и самую низкую температуры. Сколько месяцев в году было теплых(температура", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.