Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить программу, чтобы компьютер по закону Ома для участка цепи, запрашивая с клавиатуры значения напряжения на концах участка и его сопротивления,

10-11 класс

определял и выводил на экран значение силы тока (I=U/R).

Kiwi98 11 авг. 2013 г., 13:03:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tolja0323
11 авг. 2013 г., 14:24:42 (10 лет назад)

var
  u,r,i:real;
begin
writeln('Введите напряжение: ');
readln(u);
writeln('Введите сопротивление: ');
readln(r);
i:=u/r;
writeln('Сила тока равна ',i)
end.

+ 0 -
Александр163
11 авг. 2013 г., 15:29:25 (10 лет назад)

Комментарий удален

+ 0 -
Alonka1203
11 авг. 2013 г., 17:28:17 (10 лет назад)

паскаль

Ответить

Другие вопросы из категории

Нужно решение) кто способен?

Вопрос 1.
На одномернный массив, вывести его в порядочный вид по убыванию!

Целесообразно ли с точки зрения безопасности компьютерной

системы объединение в одном лице функций администратора и аудитора?

алгоритм Мишень цел n, k, i вещ массив P[1000] вещ r1, r2 начало ввести

n, массив P и радиусы r1, r2 /* Исходные данные */

вывести заголовок задачи и значения n, P, r1, r2 k ¬0 для i от 1 до n шаг 1 выполнять/*

Подсчитать число точек */ если r1 < ri и ri < r2 то k ¬k +1

конец-если

конец-цикл

вывести заголовки выходных данных и значений k конец

Теперь спланируем тестирование.

Проверку программы выполним при следующих исходных данных.

Зададим число точек на плоскости: n = 10. Подберем расстояния и радиусы: 0.03 21.0 12.89 7.41 99.99

P = 12.34 56.78 90.98 7.6 0.54

r1 = 12.35 r2 = 56.90.

Выходные данные в этой задаче будут иметь вид: Мишень Исходные данные:

n= 10 Массив P[n]: 0.03 21.0 12.89 7.41 99.99 12.34 56.78 90.98 7.6 0.54 r1 = 12.35 r2 = 56.90

Ответ: внутри 3 точки (три точки находятся внутри кольца).помогите написать программа в паскале и алгоритм блок-схему.пожалуйста срочно!

Дан массив: BBABBAAA. К чему Незнайка применил следующий алгоритм: если первый элемент массива равен"А", то меняем местами перые два элемента массива, а

если же первый элемент массива равен "B" , то переносим его на третью с конца позицию.Каку юпоследовательность получил Незнайка, если данный алгоритм он применил 6 раз?

Читайте также

Составить программу на языке Паскаль

Известна температура больного за 20 дней пребывания в больнице. Можно ли еговыписывать, если для этого требуется, чтобы не менее половины всех дней, когда у негобыла температура ниже 37°, приходилось на вторую половину его пребывания вбольнице?

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.



Вы находитесь на странице вопроса "Составить программу, чтобы компьютер по закону Ома для участка цепи, запрашивая с клавиатуры значения напряжения на концах участка и его сопротивления,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.