Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

В трехзначном числе x зачеркнули его вторую цифру. Когда к

5-9 класс

образовавшемуся двухзначному числу справа приписали вторую цифру числа x, то получилось число n. По заданному n найти число x
(значение n вводится с клавиатуры).

Dudlermen 31 авг. 2013 г., 12:56:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pavel1368
31 авг. 2013 г., 13:52:59 (10 лет назад)

Если внимательно прочитать условие задачи, то становится понятно, что вторая цифра числа меняется с третьей и нужно поменять их снова.

var
  a, b, c, n, x: integer;

begin
  Write('Введите число n -> ');
  Readln(n);
  a := n div 100;
  c:=(n div 10) mod 10;
  b:=n mod 10;
  x:=100*a+10*b+c;
  Writeln(x);
end.

Тестовое решение:

Введите число n -> 482
428


Ответить

Другие вопросы из категории

Паскаль. Оператор выбора.

Дано натуральное число N (N<100), что означает возраст человека в годах. Дать для этого числа наименование: "год", "года", "лет".

Помогите, пожалуйста! Два игрока играют в следующую игру. Перед ними лежит куча из 6 камней. Игроки берут камни по очереди, за один ход можно

взять 1, 2 или 3 камня.Проигрывает тот, кто забирает последний камень. Кто выигрывает при безошибочной игре обоих игроков - игрок, делающий первый ход, или игрок, делающий второй ход? Каким должен быть первый ход выигрующего игрока? Ответ обоснуйте.

Читайте также

ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТА. РЕШИТЬ БЛОК-СХЕМОЙ

В трехзначном числе x зачеркнули его вторую цифру, когда к образованному при этом двузначному числу приписали вторую цифру числа x, то получилось число n. Найдите число x

1. Если дано трехзначное число, например 123 его можно представить в

виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу,
которая, получая от пользователя трехзначное число, будет определять из каких цифр
оно состоит и выводить их через пробел (например, 1_2_3).



Вы находитесь на странице вопроса "В трехзначном числе x зачеркнули его вторую цифру. Когда к", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.