Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

как сделать программку через паскаль авс чтобы высчитывала объём и площадь пиромиды

5-9 класс

помогите пожалуйста

Antiangel87 17 окт. 2014 г., 19:36:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
фаааак
17 окт. 2014 г., 21:19:40 (9 лет назад)

Код не мой, не знаю, на счет правильности,
Var S: real;
               x: Array [1..5] of Real;
               y: Array [1..5] of Real;
               z: Array [1..5] of Real;
           i,n,m: Integer;

{процедура вычисления площади треугольника}
procedure plosh(x_1,y_1,z_1,x_2,y_2,z_2,x_3,y_3,z_3:real);
var
a,b,c,p,t:real;
begin
 a:=sqrt(sqr(y_2-y_3)+sqr(x_2-x_3)+sqr(z_2-z_3));
 b:=sqrt(sqr(y_1-y_3)+sqr(x_1-x_3)+sqr(z_1-z_3));
 c:=sqrt(sqr(y_1-y_2)+sqr(x_1-x_2)+sqr(z_1-z_2));
 p:=(a+b+c)/2;
 t:=p*sqrt((p-a)*(p-b)*(p-c));
end;

{заносим в массив координаты вершин}
for i:=1 to 5 do
begin
 if i:=1 or 5 then
  begin
   write('X',i,' -> '); readln(x[i]);
   write('Y',i,' -> '); readln(y[i]);
   write('Z',i,' -> '); readln(z[i]);
  end;
 else
  begin
   write('X',i,' -> '); readln(x[i]);
   write('Y',i,' -> '); readln(y[i]);
   z[i]:=z[1]
   writeln;
  end;
 end;
end;
{начинаем перебор всех вариантов сочетания вершин, создающих треугольник}
for i:=1 to 5 do
for n:=1 to 5 do
for m:=1 to 5 do
begin
 if ((i<>n) and ((n<>m) and (i<>m))) then
 begin
plosh(x[i],y[i],z[i],x[n],y[n],z[n],x[m],y[m],z[m]);
 end;
end;

+ 0 -
1в1а1л1я
18 окт. 2014 г., 0:16:40 (9 лет назад)

Комментарий удален

+ 0 -
Егор574
18 окт. 2014 г., 3:00:18 (9 лет назад)

Комментарий удален

+ 0 -
Tisolo
18 окт. 2014 г., 5:14:24 (9 лет назад)

Комментарий удален

+ 0 -
KapranovaDashaASINO
18 окт. 2014 г., 6:27:09 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Срочно!

Программа Паскаль.
Пожалуйста, помогите решить задачу и составить программу.

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки,

затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

помогите, пожалуйста.

Сколько нужно посадить кустов
помидоров, чтобы продав их на рынке за 20 р. за килограмм, получить прибыль
1000 р.? В среднем с одного куста можно собрать до 30 кг. Отчисления на налоги
составляют 20% от выручки и от оставшейся суммы нужно заплатить 10% за место
торговли

Читайте также

1)как можно описать в паскале массив в котором будут хранится значения численности населения Москвы к концу каждого года 20 века.2) Вы приобрели

котенка.Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив,в котором будут хранится значения веса котенка в течение мая.3)На основе этих заданий надо составить фрагмент программы на Паскале ввода исходных данных для массивов.

1)Как можно описать на Паскале 1)Как можно описать на Паскале массив,в котором будет храниться значения численности населения Москвы к концу

каждого года XX века?
2)Вы приобрели котёнка.Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив,в котором будет храниться значения веса котёнка в течение месяца (например,мая)?

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)



Вы находитесь на странице вопроса "как сделать программку через паскаль авс чтобы высчитывала объём и площадь пиромиды", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.