Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Дан массив из 15 чисел посчитать количество тех чисел, у которых чётный индекс. Помогите пожалуйста.

5-9 класс

Kochina99 21 окт. 2015 г., 0:43:36 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ilvina30012004
21 окт. 2015 г., 3:35:31 (8 лет назад)

var a: array [1..15] of integer; i, s: integer;
begin
     for i := 1 to 15 do
         read(a[i]);
     s := 0;
     for i := 1 to 15 do
     if i mod 2 = 0 then
        s := s + a[i];
     writeln(s);
end.

+ 0 -
Misteralex2001
21 окт. 2015 г., 5:46:58 (8 лет назад)

тут даже программу писать не надо, ибо от 1 до 15 всегда ровно 7 четных чисел

+ 0 -
KatrinPalienko
21 окт. 2015 г., 8:46:54 (8 лет назад)

Я тут поразмыслил: может, надо найти сумму чисел с чётными индексами? Иначе зачем ещё нужен массив?

+ 0 -
27072007
21 окт. 2015 г., 10:49:24 (8 лет назад)

конечно так логичнее)

+ 0 -
Kaccаndra
21 окт. 2015 г., 12:14:26 (8 лет назад)

тогда сейчас подправлю)

+ 0 -
Yakovchuksvetl
21 окт. 2015 г., 14:21:52 (8 лет назад)

Скорее всего да.

Ответить

Другие вопросы из категории

Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления:

а) y=x10 б) y=x15

Постараться использовать минимальное количество дополнительных переменных.

Введите с клавиатуры число х.Определите, является ли данное число дробным.

Пример ввода:3.5
Пример вывода:Число дробное

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.



Вы находитесь на странице вопроса "Дан массив из 15 чисел посчитать количество тех чисел, у которых чётный индекс. Помогите пожалуйста.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.