Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

СРОЧНО!!! Дан цело численный массив .Найти: КАЖДУЮ ОТДЕЛЬНО!!!! а) удвоенную сумму положительных элементов б)Коол-во

5-9 класс

элементов массива , значения которых больше заданного числа А(А-Склавиатуры)

в)Кол-во тех элементов,значения которых положительны и не превосходят данного числа А (А-Склавиатуры)

StudentRGD 21 сент. 2016 г., 13:19:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Przhalkovskaya
21 сент. 2016 г., 16:06:59 (7 лет назад)

program massiv;

var b:array[1..100]of integer;

r,n,m,i,p,k,a:integer;

begin

randomize;writeln ('a=');readln(a);

writeln('n=');readln(n);

for i:=1 to n do begin

b[i]:=random(50)-25;

writeln('a[',i,']=');

if b[i]>0 then begin r:=r+b[i];p:=r*2;

if b[i]>a then k:=k+1;

if ((b[i]<a)and(b[i]>0)) then m:=m+1;

end;end;writeln('удвоенная сумма положительных элементов ',p);

writeln('kол-во элементов массива , значения которых больше заданного числа',k);

writeln('количество положительных элементов не превсходящих заданного числа',m);

end.

Ответить

Читайте также

HELP!!

*Дан массив А целых чисел, состоящий из 20 элементов. Заполнить с клавиатуры.
1) Создать новый массив В, каждый элемент которого равен корню квадратному элемента массива А.
2)Найти сумму элементов массива с 11 по 15.
3) Найти элемент массива кратный 8 и его индекс.
4)Найти удвоенную сумму положительных элементов.
5)Вывести индексы тех элементов, значения которых больше значения предыдущего элемента( начиная со второго).
6) Определить, есть ли 2 пары соседних элементов с одинаковыми знаками.
7)Найти количество положительных элементов.
8)Вычесть из положительных элементов элемент с номером 2, а к отрицательным прибавить элемент с номером 4.
9) Удалить из таблицы все элементы массива, кратные 3 или 5.
10) Поменять местами второй элемент массива и первый чётный.
Помогите пожалуйста. Срочно нужно)

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "СРОЧНО!!! Дан цело численный массив .Найти: КАЖДУЮ ОТДЕЛЬНО!!!! а) удвоенную сумму положительных элементов б)Коол-во", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.