Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до N

10-11 класс

pascal

Dilyaaaa 09 апр. 2017 г., 7:15:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Неки
09 апр. 2017 г., 7:59:06 (7 лет назад)

var  i, j, n, p: integer;

begin 
readln(n); 
for i := 1 to n do 
begin   
p := 0;   
for j := i - 1 downto 1 do     
if (i mod j = 0) then p := p + j;   
if p = i then writeln(i, '- совершенное число'); 
end;
end.

Ответить

Другие вопросы из категории

Реализовать на Паскале алгоритм

Дан массив F
(15). Умножить все элементы на 0.5, начиная
с первого по порядку отрицательного
числа.

Очень срочно!!!

найти среднее арифметическое значений функции y=2(x+1) на интервале x1<=x<=x2, где x1=-20, x2=10 при шаге x3=5

помогите с информатикой:

1) a=0;
for i:=1 to 4 do
a:=a*i;
write (a)

2)a:=1;
for i:=2 to 5do
a:=a+i;
write (a)

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

1)Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру.

2)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
3)Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами.
4)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.



Вы находитесь на странице вопроса "Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до N", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.