Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

решить на Паскале или Питоне, или .хотя бы алгоритм Задача: Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась.

5-9 класс

Найдите ее, зная номера оставшихся карточек. Входные данные:Дано число N, далее N-1 номер оставшихся карточек (различные числа от 1 до N).

Valetka33 23 мая 2013 г., 2:10:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
макар34
23 мая 2013 г., 3:22:38 (10 лет назад)

var n, tmp, sum, i:integer;begin     readln(n);     sum := (n * (n + 1)) div 2;     for i := 1 to n - 1 do     begin          read(tmp);          sum := sum - tmp;     end;     writeln(sum);end.

+ 0 -
Bogdan989
23 мая 2013 г., 4:17:03 (10 лет назад)

ну если правильно написать, то да

+ 0 -
АндрейВоробей
23 мая 2013 г., 6:14:29 (10 лет назад)

А как посчитать новую сумму оставшихся карточек, я никак не пойму

+ 0 -
Rlantaeva
23 мая 2013 г., 6:57:15 (10 лет назад)

в ответах написал на паскале, только форматирование слетает(

+ 0 -
сниперша
23 мая 2013 г., 7:47:31 (10 лет назад)

Не пользуйтесь браузером-Хромом, остальные нормально сохраняют

+ 0 -
Ledenevakarina
23 мая 2013 г., 9:19:16 (10 лет назад)

опера( буду файлом прикреплять

Ответить

Другие вопросы из категории

Для какого из приведённых значений числа X ложно высказывание:

(X = 9) ИЛИ НЕ (X < 10)?
1) 8 2) 9 3) 10 4) 11

В городе жили 5 друзей:Макар,Егор,Аксён, Фрол и Филимон.Профессии у них разные:один мельник,другой маляр,третий-парикмахер.Егор и Фрол никогда не держали

малярной кисти.Макар и Фрол не были на мельнице.Егор и Филимон жили в одном доме с почтальоном. Аксен гулял на свадьбе Егор и дочери парикмахера.Макар и Егор играли в городки с плотником и маляром.Фрол и Филимон брились в парикмахерской у друга.а почтальон брился сам.Кто есть кто?

сколько ГБ составляет 21,8 МБ?

Читайте также

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ. Опишите на русском языке или

на одном из языков программирования алгоритм, который подсчитывает и выводит средний балл учащихся, сдавших экзамен (получивших оценку более 20 баллов). Гарантируется, что хотя бы один ученик в классе успешно сдал экзамен.

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!



Вы находитесь на странице вопроса "решить на Паскале или Питоне, или .хотя бы алгоритм Задача: Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.