Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле:

10-11 класс


Вычислить
сумму положительных элементов матрицы А (10х10), расположенных над главной
диагональю. Индекс номера строки i изменяется
от 1 до 9, а индекс номера столбца j изменяется от –i+1
до 10.

Izastepka 16 нояб. 2013 г., 4:12:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Veraanikina02
16 нояб. 2013 г., 5:36:54 (10 лет назад)

var a:array[1..10,1..10] of integer;
i,j,sum,np: integer;
begin
for i:=1 to 10 do 
 for j:=1 to 10 do readln(a[i,j]);
sum:=0;
for np:=1 to 9 do begin
 i:=np; 
 for j:=1 to np do begin 
  if a[i,j]>0 then sum:=sum+a[i,j]; 
  i:=i-1; 
 end;
end; 
writeln('Сумма элементов, расположенных выше главной диагонали равна ',sum);
readln
end.

Ответить

Другие вопросы из категории

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.

что понимается под таблицей
Ввести массив F(n) вещественных

чисел. Если последний элемент массива положительный, то найти max среди
элементов массива и заменить его значений последний элемент массива. Массив
распечатать. Иначе – дать сообщение «Массив остался без изменений»

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

Составить блок-схему и написать программу для решения задачи. Организовать вычисление значения функции y по формуле y=4x+3/x-1 -√2x+9 для любого заданного

значения аргумента x. Учесть вывод сообщения о невозможности вычисления значения функции

Построить блок схему алгоритма и написать программу для решения: Даны действительные числа z,y,x.Если сумма двух чисел x y меньше единицы ,то каждое из

заданных трёх чисел заменить полусуммой двух других,в противном случае возвести в квадрат.

Написать программу для решения задачи

a) Удалить из текста все введенные символы.

b) В заданном тексте после каждого знака ‘–’ и перед каждым таким знаком вставить пробел, если его там нет.



Вы находитесь на странице вопроса "Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.