Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

это правильно ?

5-9 класс

это информатика 9 класс.
задача. среди 4 чисел найти максимум и минимум:
program zadacha;
var
a,b,c,d,max,min:real;
begin
writeln('vvedite kofficient a,b,c,d');
If a>b then max:=a else min:=b;
If c>d then max:=c else min:=d;
If a>c then max:=a else min:=c;

Balles2000 21 июля 2016 г., 7:25:32 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
0решек
21 июля 2016 г., 8:38:53 (7 лет назад)

USES crt;
var a,b,c,d:real;
BEGIN
clrscr;
readln(a,b,c,d);
if (a > b) and (b > c) then
writeln('Max = ',a,', Min = ',c);
if (b > a) and (a > c) then
writeln('Max = ',b,', Min = ',c);

if (a > c) and (c > b) then
writeln('Max = ',a,' Min = ',b);
if (c > a) and (a > b) then
writeln('Max = ',c,', Min = ',b);
if (b > c) and (c > a) then
writeln('Max = ',b,', Min = ',a);
if (b > d) and (d > b) then
writeln('Max = ',b,', Min = ',b);
if (d > b) and (d > b) then
writeln('Max = ',d,', Min = ',a);
readln;
END.
Задача легкая, но блин, пришлось подумать...

+ 0 -
VedutaRoman
21 июля 2016 г., 9:18:04 (7 лет назад)

И если вводишь числа в строчку, то используй write, и соотв. read

+ 0 -
Milkiyei1
21 июля 2016 г., 12:11:02 (7 лет назад)

вы можете дописать просто я незнаю как

+ 0 -
аделя0
21 июля 2016 г., 12:48:40 (7 лет назад)

пожалйуста

+ 0 -
Kuuyo9876
21 июля 2016 г., 14:42:34 (7 лет назад)

не правильно условие записаны

+ 0 -
жасфедя
21 июля 2016 г., 15:26:27 (7 лет назад)

запишите пожалуйста

Ответить

Другие вопросы из категории

C1. Составить алгоритм и написать программу на

вычисление скорости или пути , при
условии , если t < 1 часа , тогда вычисляем скорость
иначе путь . Каждую строку программы прокомментировать .
Входные данные t = 40 мин.

Читайте также

У МЕНЯ ПОЛУЧИЛОСЬ ЛККР. Это правильно?

Все 4-буквенные слова, составленные из букв К, Л, Р, Т, записаны
в алфавитном порядке и пронумерованы.
Вот начало списка:
1. КККК
2. КККЛ
3. КККР
4. КККТ
……
Запишите слово, которое стоит под номером 67.

1 В состав основных устройств ЭВМ входят...

• монитор, системный блок, клавиатура, "мышка"

• память, центральный процессор, устройства ввода и вывода

• центральный процессор, видеомонитор, клавиатура

• дисковод, принтер, монитор, системный блок

2 К характеристике ЭВМ НЕ относится

• ёмкость памяти

• надежность

• стоимость

• долговечность

3 За единицу измерения кол-ва информации принят:

• 1 байт

• 1 бод

• 1 бар

• 1 бит

4 Правильный порядок возрастания единиц измерения информации

• байт, Кбайт, Мбайт, Гбайт

• бит, байт, Гбайт, Кбайт

• Кбайт, Гбайт, Мбайт, байт

• байт, Мбайт, Кбайт, Гбайт

5 Современный компьютер - это

• устройство для обработки текстов

• многофункциональное устройство для работы с информацией

• быстродействующее вычислительное устройство

• устройство для хранения информации

6 Из какого устройства процессор выбирает команды

• клавиатуры

• внешних запоминающих устройств

• оперативной памяти

• дисплея

7 Память ЭВМ служит для:

• хранения программ

• хранения программ и данных

• обработки данных

• хранения данных и выполняемой программы

8 Основная функция центрального процессора

• управление вычислительным процессом

• обработка данных

• обработка данных и управление вычислительным процессом

• хранение и передача результата работы программы

9 К устройству ввода НЕ относится

• клавиатура

• сканер

• принтер

• дисковод

10 Что НЕ является основным устройством ЭВМ

• память

• центральный процессоp

• видеоадаптер

• устройства ввода-вывода

1. Русский царь петр | прорубил это в Европу это бывает на экране при работе компьютера и является основой в названии операционной

системы для персональных компьютеров. Что это?
2. С помощью этого коня ахейцы одержали победу над царем Приамом. Сегодня так называют один из самых известных компьютерных вирусов. О каком вирусе идет речь?
3. В одной многодетной семье у каждого из пяти сыновей было по три сестры. Сколько детей в этой семье?
4. Вписав недостающее пятое число, завершите ряд: 77, 49, 36, 18 ....

Выберите правильные ответы

1. Закончите предложение: «Алгоритмом называется …»
а) нумерованный список б) маркированный список
в) система команд исполнителя
г) конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату
2. Что можно считать алгоритмом?
а) правила техники безопасности б) список класса
в) кулинарный рецепт г) перечень обязанностей дежурного по классу
3. Закончите предложение: «Блок-схема – форма записи алгоритмов, при которой для обозначения различных шагов алгоритма используются ….»
а) рисунки б) списки в) геометрические фигуры г) формулы
4. Закончите предложение: «Геометрическая фигура параллелограмм
используется в блок-схемах для обозначения ….
а) начала и конца алгоритма б) ввода или вывода данных
в) принятия решения г) выполнения действия
5. У какого из известных Вам исполнителей следующая СКИ: вверх, вниз, вправо, влево, закрасить?
а) РОБОТ б) Чертежник в) Вычислитель г) ГРИС
6. В следующем списке 12 2,3 0 5 -5 98,0 целых величин:
а) 2 б) 3 в) 4 г) 5
7. Каждая команда алгоритма должна определять однозначное действие исполнителя. Это свойство алгоритма называется…
а ) формальность б) точность в) понятность г) массовость
8. Укажите формальных исполнителей:
а) симфонический оркестр исполняет музыку Ф. Шопена
б) ученик 9 класса решает задачу по алгебре
в) фармацевт готовит лекарство по рецепту
г) автомат на конвейере наполняет бутылки лимонадом
9. Для многократного выполнения одинаковых действий в алгоритме нужно использовать
а) ветвление б) цикл в) линейные команды
10. После выполнения фрагмента алгоритма вида:
S:=0
i:=1
пока i<4
нц
i:=i+1
S:=S+1
кц
значение переменной s равно…. а) 0 б) 3 в) 5 г) 9
11. Переменная х получила значение, равное -6. Какое значение получит переменная у после выполнения ветвления:
если а меньше или равно 3
то у:=а*а
иначе у:= 2а-3
все
а) -6 б) 6 в) 36 г) -15



Вы находитесь на странице вопроса "это правильно ?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.