Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

3. Записать логические формулы, истинные при выполнении следующих условий:

10-11 класс

а) хотя бы одно из чисел X, Y, Z положительно;
б) каждое из чисел X, Y, Z равно 0;
в) только одно из чисел X, Y, Z не больше 100.

Anna8Sofi 06 нояб. 2016 г., 13:30:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akozhadej
06 нояб. 2016 г., 14:39:06 (7 лет назад)

а) (X > 0) or (Y > 0) or (Z > 0)
б) (X = 0) and (Y = 0) and (Z = 0)
в) (X > 100) and (Y > 100) and (Z <= 100) or (X > 100) and (Y <= 100) and (Z > 100) or (X <= 100) and (Y > 100) and (Z > 100)

Ответить

Другие вопросы из категории

1.Переведите

известным вам способом число 12 в
двоичную систему счисления.

В некоторой стране автомобильный номер длиной 6 символов составляется из заглавных букв (всего используется 12 букв) и десятичных цифр в любом

порядке. Каждый символ кодируется одинаковым и минимально возможным количеством бит, а каждый номер – одинаковым и минимально возможным количеством байт. Определите объем памяти, необходимый для хранения 32 автомобильных номеров.

Паскаль:

Дан массив "А" состоящий из 10 случайных чисел, сформировать новый массив "В", значения которого будут в 5 раз меньше значения массива "А"

Составьте блок-схему и прогроамму на языке PascalABC для вычисления площади прямоугольника.Рекомендуемый вид экрана во время работы приведён

ниже(данные,введённые пользователем выделены полужирным шрифтом).
Исходные данные:
Длина(см):9
Ширина(см):7.5


Читайте также

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b

Задание

Определить без компьютера, что будет напечатано при выполнении следующих фрагментов программ:
1. k:=20; k:=k+10; if k+10<>30 then k:=8 else k:=k-1; WriteLn (k)
Ответ:
2. k:=20; k:=k+10; if k+10 = 30 then k:=8 else k:=k-1; WriteLn (k)
Ответ:
3. p:=1; if p>0 then p:=p+5; Write (p); if p>10 then p:=p+1; Write (p)
Ответ:
4. p:=5; if p>0 then p:=p*2 else p:=12; if p>5 then p:=p-1 else p:=p+1; WriteLn(p);
Ответ:
5. p:=0;p:=p+1; if p=0 then p:=5 else p:=p-1; WriteLn(p);
Ответ:
6*. p:=5;p:=p*2; if p mod 2=0 then WriteLn(p) else WriteLn(0);
Ответ:

Практичекая по информатики.Помогите пожалуйста

1. Какие значения будет принимать величина- счетчик при выполнении следующего цикла: от f=100 до 1000 шаг a
2. Количество рыбы в реке, в которую сбрасывались загрязнения, ежегодно сокращалось на 20%. Определить, через сколько лет в реке почти не останется (ее количество будет меньше 1) рыбы? Извеcтно, что до начала загрязнения ее было N особей.

1. Какие значения будет принимать величина- счетчик при выполнении следующего цикла: от p=7 до -7 шаг

-1.

2. Вычислить все квадраты двухзначных чисел, не превышающих 100

Тест по паскалю!!!

100. Назовите все отличия функций от процедур?
а) функция передает в точку вызова скалярное значение, а процедура - нет
б) имя процедуры может состоять из трех символов, а функция - нет
в) процедура имеет структуру, повторяющую структуру программы, а в функции отсутствует блок описания переменных
г) имя функции может входить в выражении как операнд

101. С помощью каких параметров происходит передача данных из главной программы в подпрограмму?
а) фактических
б) формальных
в) неформальных
г) подпрограммных

102. Выберите неправильную форму записи оператора цикла
а) WHILE I<5 DO I:=I+1
б) WHILE I<5 DO BEGIN I:=I+1; WRITELN(I); END
в) WHILE I<5 TO BEGIN I:=I+1; WRITELN(I); END

103. Какое выражение обеспечивает генерирование случайных чисел в диапазоне [4,10[
а) 4+RANDOM(6)
б) 6+RANDOM(4)
в) RANDOM(4,6)

104. что означает FV в команде read(FV, x1, x2,..., xn) в Паскале ?
а) формат ввода
б) переменную, связанную с файлом, откуда берется информация
в) фиксированную величину
г) первую переменную величину для ввода информации

105. Каким окажется результат выполнения следующего фрагмента кода X:= 5; Y:= X+1; Writeln('Х=',X, Y=',Y);?
а) X=6 Y=5
б) X=5 Y=5
в) X=5 Y=6

106. Какое значение примет переменная Х после выполнения команды X:=SQR(4)/2*2?
а) 4
б) 2
в) 16

107. Каким окажется результат выполнения следующего фрагмента кода: X:= 5; Y:= 8; Т:= Х; X:=Y; Y:= T; Writeln('Х=', X, Y=',Y);?
а) X=5 Y=8
б) X=8 Y=5
в) X=5 Y=5

108. Логическое выражение
(N Mod 10 Mod 2) Or (N Div 10 Mod 10 Mod 2 = 0) Or (N Div 100 Mod 2 = 0)
должно принимать значение TRUE тогда и только тогда, когда истинно высказывание
а) в трёхзначном натуральном числе все цифры чётные
б) в трёхзначном натуральном числе одна чётная цифра
в) в трёхзначном натуральном числе две чётных цифры
г) в трёхзначном натуральном числе хотя бы одна чётная цифра

109. Цикл в фрагменте программы P := 4; Repeat P := P * 0.1 Until P < 0.0001; будет исполнен?
а) 0 раз
б) 1 раз
в) 4 раза
г) 5 раз

110. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) -1
б) False
в) True
г) 0

111. Значения переменных a и b после выполнения следующих действий
a := 15 Div (16 Mod 7); b := 34 Mod a * 5 - 29 Mod 5 * 2;
будут равны
а) a = 1, b = 160
б) a = 1, b = 4
в) a = 7, b = 25
г) a = 7, b = 22

112. Во фрагмент алгоритма, печатающий все двузначные числа, в записи которых есть цифра N или сумма цифр которых равна самим числам, нужно вписать логическое выражение
а) (P1 = N) Or (P2 = N) And (S = K)
б) (P1 = N) Or (P2 = N) Or (S = K)
в) (P1 = N) And (P2 = N) Or (S = K)
г) ((P1 = N) Or (P2 = N)) And (S = K)

113. Тело цикла в программе a := 1; b := 1; While a + b < 8 Do begin a := a + 1; b := b + 2 end;
выполнится?
а) 1 раз
б) 2 раза
в) 3 раза
г) бесконечное число раз

114. Задана строка St (см Фрагмент алгоритма)
а) определяет количество цифр в строке
б) подсчитывает количество нулей в строке
в) определяет сумму номеров позиций в строке, где стоят цифры
г) подсчитывает сумму цифр в строке;

115. Задан двумерный массив X[1..n, 1..m]. Процедура
а) к элементам столбцов в первой половине матрицы прибавляет элементы первого столбца соответствующей строки
б) добавляет к матрице еще M столбцов с элементами, равными соответствующим элементам первого столбца
в) к элементам четных столбцов прибавляет элементы первого столбца соответствующей строки
г) к элементам четных строк прибавляет элементы первой строки соответствующего столбца;

116. Задан двумерный массив X[1..n, 1..m]. Функция возвращает значение
а) True, если все элементы массива ненулевые
б) True, если в массиве есть элемент, равный нулю
в) False, если в массиве есть элемент, равный нулю
г) Not t;

117. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) 1
б) False
в) True
г) 0

118. В каком фрагменте программы подсчитывается сумма элементов квадратной матрицы, расположенных выше главной диагонали?

а) For i:= 1 to n do
For j:= 1 to n do
If i<=j then
S:=s+a[I,j];

б) For i:= 1 to n do
For j:= i+1 to n do
S:=s+a[I,j];

в) For i:= 1 to n do
For j:= 1 to n do
If i>j then
S:=s+a[I,j];




Вы находитесь на странице вопроса "3. Записать логические формулы, истинные при выполнении следующих условий:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.