Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите составить программу на языке программирования visual c++! Два автомобиля движутся по кольцевой дороге длины

10-11 класс

Abigor5333 25 марта 2017 г., 2:26:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelinochka1999
25 марта 2017 г., 3:47:18 (7 лет назад)

#include<iostream>
using namespace std;
int main(){
  int l,v1,v2,t;
  cin>>l>>v1>>v2>>t;
  int x1 = (t * v1)%l,x2 = (-t*v2)%l;
  if(x1<0) x1=l-x1;
  if(x2<0) x2=l+x2;
  cout<<min(abs(x1-x2),abs(l-x1-x2));
}

Ответить

Другие вопросы из категории

Написать программу, определяющую состоит ли трехзначное число из одинаковых цифр.

Подсказка: в материалах урока есть программа по определению цифр в двузначном числе!

Выбери верное утверждение.

1) Для облачного сервера можно динамически изменять используемые ресурсы памяти процессора.
2) Облачный сервер всегда должен находиться в другой организации.
3) Физический сервер может обслуживать только запросы, приходящие о т зарегистрированных пользователей.
4) На физический сервер можно установить и Linux и Windows, а на облачный только Windows.

помогите пожалуйста составить программу паскаль и объясните ее

дано четырехзначное число,получить новое поменяв местами первую и последнюю цифру

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

Помогите составить программу на языке PASCAL

В матрице X(5×5) определите произведение положительных элементов
главной диагонали.



Вы находитесь на странице вопроса "Помогите составить программу на языке программирования visual c++! Два автомобиля движутся по кольцевой дороге длины", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.