Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Составьте программу, которая формирует массив из 20 целых чисел и находит индексы находит индексы нулевых элементов.

5-9 класс

Lovekillsxx 10 нояб. 2013 г., 23:11:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zaurbek9586
10 нояб. 2013 г., 23:55:55 (10 лет назад)

Program enot;
Var a:array[1..20] of integer;
 i: integer;
begin
for i:= 1 to 20 do
 a[i]:= random(10)-5;
for i:= 1 to 20 do
if a[i]=0 then
 write(i,'; ');
end.

Ответить

Другие вопросы из категории

Петя и Коля пишут друг другу электронные письма в кодировке КОИ-8. Однажды Петя ошибся и отправил письмо в кодировке Windows. Коля получил письмо и,

как всегда, прочитал его в КОИ-8. Получился бессмысленный текст, одно из предложений которого имело вид: кЧАЮЪ ХМТНПЛЮЖХЪ ЛНФЕР АШРЭ ОПЕДЯРЮБКЕМЮ Я ОНЛНЫЭЧ ВХЯЕК. какое предложение было в исходном виде???

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы



Вы находитесь на странице вопроса "Составьте программу, которая формирует массив из 20 целых чисел и находит индексы находит индексы нулевых элементов.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.