Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Chr (Ord ('5')-2))=

10-11 класс

sqrt (.sqr (35)+ Sqr(12))=

KostyanCheb 22 февр. 2014 г., 16:52:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olga16082002
22 февр. 2014 г., 18:40:06 (10 лет назад)

1) ord('5') = 53
ord('5') - 2 = 51
chr(ord('5')-2) = '3'

2) sqr(35) = 1225
sqr(12) = 144
sqr(35)+sqr(12)=1369
sqrt(sqr(35)+sqr(12)) = 37

Ответить

Другие вопросы из категории

Программисты, выручайте!

1. Проверить, являются ли элементы одномерного числового массива членами арифметической последовательности, желательно на С++

Приближается очередная олимпиада по программированию, и товарищи A и B решили устроить совместную тренировку. Они выбрали n задач и договорились,

что тренировка продлится t минут.Для каждой задачи известно время si (i = 1; 2; : : : ; n), которое потребуется на её решение. Уровень подготовки у товарищей A и B одинаковый, и если товарищ A решает некоторую задачу за время s, то и товарищ B решает эту задачу за это же время s.Товарищ A начал решать задачи с первой и будет решать их подряд, двигаясь от первой к последней и не пропуская ни одной. Товарищ B начал решать задачи с последней и тоже будетрешать их подряд, двигаясь от последней к первой и не пропуская ни одной.Ваша же задача — определить, сколько задач решат в течение тренировки товарищи A и B.В качестве ответа выведите два целых числа: количество задач, которые решит товарищ A, и через пробел — количество задач, которые решит товарищ B.

Формат входного файла

В первой строке содержатся через пробел два целых числа — n (1 n 100) и t (1 t 1000).
Во второй строке содержатся n целых чисел s1; s2; : : : sn (1 si 1000; i = 1; 2; : : : ; n), также отделённые друг от друга пробелом.

Формат выходного файла

В единственной строке выходного файла содержатся два целых числа через пробел — количество задач, которые решит товарищ A, и количество задач, которые решит товарищ B соответственно.

На Паскаль :)

Читайте также

Проверьте пожалуйста программу.

program f_3;
var f1, f2, f3:text;
C:integer;
G:char;
s:string;
sp:string;
begin
s:=('');
sp:=(' ');
Assign(f1, 't.txt');
Assign(f2, 't2.txt');
Assign(f3, 't3.txt');
Reset(f1);
Rewrite(f2);
Rewrite(f3);
while not eof(f1) do
begin
readln(f1,G);
C:=ord(G);
writeln(f2,inttostr(C));
end;
Reset(f2);
while not eof(f2) do
begin
readln(f2,C);
G:=chr(C);
writeln(f3,G);
end;
close(f1);
close(f2);
close(f3);
end.


С помощью Паскаля: Число в двоичной системе счисления, введенное

пользователем программы, преобразовать в десятичное число.
Используя цикл! Желательно попроще (без length, ord, exp).



Вы находитесь на странице вопроса "Chr (Ord ('5')-2))=", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.