Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите написать программу которая по данному натуральному числу от 1 до 2 (номеру месяца) выдает все приходящихся на этот месяц праздничные

5-9 класс

дни(например, если введено число 1, то; 1 января - новый год , 7 января - Рождество).

КохейриНЯ 06 мая 2014 г., 11:14:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maria258
06 мая 2014 г., 12:14:06 (9 лет назад)

var
  n: integer;

begin
  write('Введите номер месяца (1-12): ');
  readln(n);
  case n of
    1: writeln('1 января - Новый год; 7 января - Рождество Христово');
    2: writeln('23 февраля - День защитника Отечества');
    3: writeln('8 марта - Международный женский день');
    5:
      begin
        writeln('1 мая - Праздник Весны и Труда;');
        writeln('9 мая - День победы советского народа в Великой Отечественной войне 1941-19545 годов')
      end;
    6: writeln('12 июня - День России');
    11: writeln('4 ноября - День народного единства')
  end
end.

Тестовое решение:

Введите номер месяца (1-12): 6
12 июня - День России



+ 0 -
Dashaedinorog
06 мая 2014 г., 13:16:41 (9 лет назад)

1 до 12

+ 0 -
Ryabichenkokat
06 мая 2014 г., 14:10:12 (9 лет назад)

В pascal abc

+ 0 -
Sparkiboomen
06 мая 2014 г., 15:08:11 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

однажды в артеке за круглым столом оказалось 5 ребят родом из Москвы Новгорода Перми Санкт- Петербурга и Томска: Юра Толя Алёша Коля Витя.

Москвия сидел мужду томичем и Витей,санкт-петербужец - между Юрой и Толей,

а напротив него сидели пермяки Алёша. Коля никогда не бывал в Санкт- Петербурге, Юра не был в Москве и Томске, а томич с Толей регулярно переписываются .

Определите в каком городе живёт каждый из ребят.

Кто является первым программистом в истории человечества

(из заслуг - введение понятий " цикл" и " рабочая ячейка”)

Читайте также

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.



Вы находитесь на странице вопроса "Помогите написать программу которая по данному натуральному числу от 1 до 2 (номеру месяца) выдает все приходящихся на этот месяц праздничные", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.