Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

От прямоугольника 324х141 отрезают квадраты со

10-11 класс

стороной 141, пока это возможно. Затем вновь отрезают квадраты со стороной,
равной 324-2*141=42 и т.д. На какие квадраты и насколько будет разделен прямоугольник?
Решение программы в Pascal ABC

Likiliks 13 нояб. 2013 г., 14:16:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alina876
13 нояб. 2013 г., 17:10:18 (10 лет назад)

program chet;
var a,b,k,z:integer;
begin
a:=324;
b:=141;
k:=1;//т.к. как только a=b это +2 квадрата
while a<>b do
begin
if a>b then begin
a:=a-b;
k:=k+1;
writeln(b);
end
else
begin
z:=b;
b:=a;
a:=z;
end;
end;
writeln('Квадратов',k);
end.

P.S. Он будет ввыводить в столбик стороны квадртов и по склько брали этот квадрат.

+ 0 -
Kushsv2003
13 нояб. 2013 г., 19:06:19 (10 лет назад)

Не понимаю смысл фразы 'и тд'

Ответить

Другие вопросы из категории

Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, определяющую общую

длину пробега за месяц и первый день с начала тренировок, после которого дистанция превысит 25 км.
паскаль!!!

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Читайте также

Дан прямоугольник с размерами 425Х131. От него отрезают квадраты со стороной 131, пока это возможно. Затем от оставшегося прямоугольника вновь отрезают

квадраты со стороной, равной 425-131*3=32, и т.д. На какие квадраты и в каком их количестве будет разрезан исходный прямоугольник?

Дан прямоугольник. Его длина равна a

мм, ширина – b мм. Сколько квадратов со стороной с мм можно
отрезать от него? Решить задачу средствами

Ребяят, помогите пожалуйста Задача №132. Дан прямоугольник со

сторонами a и b. Сколько квадратов со стороной с можно из него вырезать.

Составьте пожалуйста программу!!!! Даны целые положительные числа A, B, C. На прямоугольнике размера A x B размещено максимально возможное количество

квадратов со стороной C (без наложений). Найти количество квадратов, размещенных на прямоугольнике, а также площадь незанятой части прямоугольника.



Вы находитесь на странице вопроса "От прямоугольника 324х141 отрезают квадраты со", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.