Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 971 ответов!

Помогите пожалуйста!!!нужно написать программы на паскале! 1) дано целое число m>1. получить наибольшее целое k, при котором 4^k(четыре в

5-9 класс

степени k)<m.

2)дано натуральное число n, получить наименьшее число вида 2^r(два в степени r), превосходящее n.

3)дано натуральное число n. вычислить 1*2+2*3*4+...+n*(n+1)*...*2n (*-знак умножения)

4)Вычислить:

1

_____________

1

1 + _________

1

3 + _________

1

5 + ________

......

1

101 + ___

103

(______________ - дробь)

помогите чем сможете, пожалуйста!

Alexey890 09 сент. 2016 г., 16:40:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Egor16133
09 сент. 2016 г., 18:24:29 (7 лет назад)

program z1;
var
i,j,m,k,z,x,l:integer;
begin
readln(m);
for i:=0 to m do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*4;
x:=x-1;
end; end;
if ((z<m) and (z*4>m)) then writeln(i);
if z=m then writeln(i-1);
end;
end.

 

program z2;
var
i,j,n,k,z,x,l:integer;
begin
readln(n);
for i:=0 to n do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*2;
x:=x-1;
end; end;
if ((z>n) and (z/2<n)) then writeln(i);
if z=n then writeln(i+1);
end;
end.

 

program z3;
var
i,j,n,k,z,x,s:integer;
begin
readln(n); s:=0;
for i:=1 to n do begin z:=1;
for j:=i to 2*i do
z:=z*j;
s:=s+z; end;
writeln(s);
end.

 

время 2 ночи 

...думаю пора спать ) 


Ответить

Другие вопросы из категории

Составьте программу,которая спрашивает у ученика :"какую оценку ты получил за контрольную работу?"и в зависимости от ответа выдаетразличные сообщения:

5- это отличный результат,4- не плохо ,но есть к чему стремитьсяв будущем! 3- ты можешь и лучше! 2 - ой,печалька!

Читайте также

Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Помогите!Очень нужно)))

В строке символов определить кол-во букв А.
Нужно составить программу на Паскале))

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "Помогите пожалуйста!!!нужно написать программы на паскале! 1) дано целое число m&gt;1. получить наибольшее целое k, при котором 4^k(четыре в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.