Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число. помогите

5-9 класс

пожжалуйста..

25673ьои 20 апр. 2013 г., 16:28:45 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zayka160
20 апр. 2013 г., 18:16:18 (11 лет назад)

program NandM;

 var n,m,r: integer;

        c,d: real;

Begin

   writeln ('Enter n,m');

   readln (n,m);

r:=random(500);

c:=n mod m;

d:=m mod n;

If (c=0)or(d=0) then writeln ('1') else writeln ('r');

readln;

End.

 

 

Ответить

Другие вопросы из категории

Напечатать следующим образом

21 20,4
22 21,4
...
35 34,4

Помогите с информатикой

нужно выполнить переводы чисел из одной системы в другую

Петя и Коля пишут друг другу электронные письма в кодировке КОИ-8.Однажды Петя ошибся и отправил письмо в кодировке Windows.Коля получил письмо и,как

всегда прочитал его в КОИ-8 .Получился бессмысленный текст: кЧАЮЪ ХМТНПЛЮЖХЪ ЛНФЕР АШРЭ ОПРЕДЯРЮБКЕМ Я ОНЛНЫЭЧ ВХЯЕК. Какое предложение было исходным? Для расшифровки сообщения пользуйтесь таблицей в учебнике 5 КЛАСС

Читайте также

Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения

увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.5;2,0], то оба значения уменьшить в 10 раз ; в остальных случаях x и y остаются без изменения . Помогите , завтра зачет.

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива

1)Составьте программу, которая заполняет массив a [1...10] случайными целыми числами в диапазоне от 1 до 20 и вывода на экран элементов массива с

нечётными значениями.
2) Соединить :D
1- двоичный код
2- кодирование
3- система счисления
4- основание
5- разряд
а- Процесс преобразования информации из одной форму представления в другую
б- Набор из нулей и едениц
в- Позиция цифры в числе
г- Способ запичи чисел
д- Число цифр, которые используются в системе счисления для записи чисел

1. дано натуральное двух значное число определить будет ли цыфра десятков больше чем цыфра единиц.Тема паскаль 2) даны два

натуральных числа вывести на экран то из них у которого цыфра меньше. пожалуйста решите 2 задачи

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.



Вы находитесь на странице вопроса "Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число. помогите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.