Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С помощью Паскаля:

5-9 класс

1.В магазине продается мастика в ящиках по 15 кг,17 кг,21 кг. Как купить ровно 185 кг мастики, не вскрывая ящики?Сколькими способами можно это сделать?
2.Ввести натуральное число N и вывести все натуральные числа,не превосходящие N и делящиеся на каждую из своих цифр. Пример: Введите N: 15 1 2 3 4 5 6 7 8 9 11 12 15.

Matrenapro100 10 дек. 2013 г., 13:23:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Slik982
10 дек. 2013 г., 15:31:21 (10 лет назад)

2) Program asd;
USES crt;
Var n,i,t,p:integer;
BEGIN
Clrscr;
readln(n);
for i:=1 to n do
begin
t:=i;
p:=1;
repeat
p:=p*(t mod 10);
t:=t div 10;
until t=0;
if (p<>0)and(i mod p=0)
then
write(i,' ');
end;
Readln;
END.
Сейчас первую дорешаю

Ответить

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.



Вы находитесь на странице вопроса "С помощью Паскаля:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.