Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

5-9 класс

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Cfrg 18 марта 2014 г., 3:30:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikita42
18 марта 2014 г., 5:36:56 (10 лет назад)

В общем виде так(выводит вектор случайных чисел, сумму чисел<10 и сумму чисел кратных 3):

program test;
var
arr:array[1..40] of integer;
i,sum1,sum2:integer;
begin
for i:=1 to 40 do
begin
 arr[i]:=random(21);
 write(arr[i],' ');
 if arr[i]<=10 then sum1:=sum1+arr[i];
 if (arr[i] mod 3) = 0 then sum2:=sum2+arr[i];
end;
writeln;
writeln(sum1);
writeln(sum2);
readln;
end.

+ 0 -
Dianagirl18
18 марта 2014 г., 6:26:55 (10 лет назад)

program kol;
uses crt;
var
n:array [1..40] of integer;
sum10,sum3,i:integer;
begin
 randomize;
for i:=1 to 40 do begin
n[i]:=random(20);
end;
 for i:=1 to 40 do begin
if (n[i] mod 3 =0) then
 begin
sum3:=sum3+n[i];
end;
end;
 for i:=1 to 40 do
begin if (n[i]<=10) then
begin
sum10:=sum10+n[i];
 end;
 end;
 writeln('Сумма кратных трем = ',sum3);
writeln('Сумма не превищающих 10 = ',sum10);
end.

+ 0 -
Анастасия2111
18 марта 2014 г., 7:07:55 (10 лет назад)

Мало баллов

Ответить

Другие вопросы из категории

В таблице приведены запросы и количество страниц, которые нашел поисковый сервер по этим запросам в некотором сегменте Интернета:

Запрос Количество страниц
фрегат & эсминец 500
фрегат | эсминец 4500
эсминец 2500
Сколько страниц (в тысячах) будет найдено по запросу фрегат

Дано действительное число а.Вычислите f(a), если

а) f(х)= х2 при -2≤х<2,
4 в противном случае;

б) f(x)= x2+4x+5 при х≤2,
1/х2+4х+5 в противном случае;
пожалуйста..

Читайте также

Помогите пожалуйста написать 2 программы

1)Написать программу которая меняет местами числа a и b(линейная и оператор присваивания)
2)Программа проверки существования треугольника по его 3 сторонам
Напишите пожалуйста***

задание.Составить программу по следующей схеме: Составить программу так,чтобы в строке Иван копал картофель слово картофель заменилось на редис. Или

так: Написать любое простое предложение и написать программу по счету букв считая пробелы и цифры.

Помогите с программой по информатике

Найти средний рост класса. Написать программу. 10 человек
Самый наименьший рост 162 самый высокий 170

помогите пожалуйста решить задания по информатике. Спасибо получите 100%. можно с решением пожалуйста.Задание 1.У короля было три дочери. Решил он выдать

их замуж. Пригласил женихов со всех концов света. Съехались в королевство 50 принцев и знатных юношей. Сколькими способами дочери короля могут выбрать себе женихов?
Задание2.
На одном далеком-далеком острове жило-было маленькое племя. В языке этого племени было всего 5 прилагательных, 15 существительных и 10 глаголов. Предложения в этом языке состояли либо из существительного и глагола, либо из прилагательного, существительного и глагола (порядок слов именно такой). Сколько всего предложений можно составить по правилам языка маленького племени?



Вы находитесь на странице вопроса "Помогите,пожалуйста,написать программу по информатике.Вот такое условие:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.