Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В Pascal

5-9 класс

X девочек и Y мальчиков пошли в кинотеатр и купили билеты на один ряд. Определите, возможно ли детям сесть так, чтобы рядом с одной девочкой сидел как минимум один мальчик и рядом с одним мальчиком сидела хотя бы одна девочка.
Входные данные:
Во входном потоке в первой строке через пробел записаны два натуральных числа X и Y (X, Y <= 100)

Выходные данные:
В выходной поток вывести YES, если возможно указаным способом рассадить мальчиков и девочек и NO в противном случае.

Пример входного файла (input.txt):
5 5

AAnAsTaSiYa11 08 июля 2014 г., 5:06:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
артемида200
08 июля 2014 г., 5:44:08 (9 лет назад)

Нарушением условия является случай, когда у мальчика (М) или у девочки (Д) оба соседа того же пола, следовательно недопустимой является расстановка МММ или ДДД. Отсюда возникает условие, что количество М и Д не могут отличаться более, чем вдвое, т.е. 0.5 ≤ X/Y ≤ 2
Программа должна учитывать особенности реализации целых и вещественных чисел в ЭВМ, а также особенности выполнения операции деления и сравнения.

var
  X, Y: integer;
  b: boolean;
  F: Text;
begin
  Assign(f,'input.txt');
  Reset(f);
  Readln(X,Y);
  Close(f);
  if X > Y then b := (X / Y <= 2)
  else b := (Y / X <= 2);
  if b then writeln('YES')
  else writeln('NO')
end.

Тестовое решение:

YES


Ответить

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "В Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.