Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводятся целые числа. Окончание ввода – число ноль. Ноль используется

5-9 класс

только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать
среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру «5».
Учесть, что таких чисел может не быть. PascalABC

Ayshakhan 01 авг. 2014 г., 9:30:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
вввввввввввввв
01 авг. 2014 г., 10:23:30 (9 лет назад)

var sum,k,a: integer;
begin
a:=1; sum:=0; k:=0;
writeln('Вводите числа');
while a<>0 do begin
readln(a);
if (a<0)and(a mod 10=-5) then begin k:=k+1; sum:=sum+a; end;
end;
if k=0 then writeln('Таких чисел нет') else writeln('Среднее арифметическое равно ', sum/k );
readln
end.

+ 0 -
вотт
01 авг. 2014 г., 12:59:43 (9 лет назад)

Pascal ABC

Ответить

Читайте также

Помогите))С клавиатуры вводится целое 4-х значное число.

Выдать сообщение о том, есть ли в этом числе четные цифры и указать их
количество.
НА ПАСКАЛЕ

помогите пож-а))) 5. Есть исполнитель «Арифмометр», который понимает следующие команды: - взять число N

(занести в память число N),

- умножить (перемножаются занесённые в память последние два числа),

- сложить (складываются занесённые в память последние два числа),

- вычесть (вычисляется разность занесенных в память последних двух чисел),

- результат (вывести результат)

Например, в результате выполнения алгоритма:

- взять число 5,

- взять число 10,

- взять число 2,

- вычесть,

- умножить,

- результат

получим ответ 40, так как 5*(10-2)=40.

Какой результат будет получен при выполнении приведённого ниже алгоритма?

- взять число 4,

- взять число 8,

- взять число 2,

- вычесть,

- взять число 10,

- умножить,

- взять число 56,

закодировать значение числа в двоичную систему а)число 117 б)число 217 в) число 317

женя готовил доклад по литературе. в докладе 12 строчек,в каждой строчке 22 символа. определить количество информации а)в 1 символе 7 бит б) в 1 символе 10 разрядов двоичного кода.
пожалуйста помогите

Есть исполнитель «Арифмометр», который понимает следующие команды:

- взять число N (занести в память число N),
- умножить (перемножаются занесённые в память последние два числа),
- сложить (складываются занесённые в память последние два числа),
- вычесть (вычисляется разность занесенных в память последних двух чисел),
- результат (вывести результат)Например, в результате выполнения алгоритма:
- взять число 5,
- взять число 10,
- взять число 2,
- вычесть,
- умножить,
- результат получим ответ 40, так как 5*(10-2)=40.
Какой результат будет получен при выполнении приведённого ниже алгоритма?
- взять число 4,
- взять число 8,
- взять число 2,
- вычесть,- взять число 10,
- умножить,- взять число 56,
- вычесть,
- вычесть,
- результат.
Дайте объяснение своему ответу (приведите формулу для вычисления).

1. Дано натуральное число n. Определить есть ли в нем цифра x. (x, n - вводятся с клавиатуры)

2. Напишите программу, которая вводит последовательность целых ненулевых чисел, признак окончания ввода - число 0. Выясните есть ли в ней хотя бы одна пара одинаковых "соседних" чисел. СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



Вы находитесь на странице вопроса "С клавиатуры вводятся целые числа. Окончание ввода – число ноль. Ноль используется", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.