Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

помогите решить пожалуйста

10-11 класс

555CAT555 10 марта 2014 г., 9:11:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
вадим289
10 марта 2014 г., 9:43:48 (10 лет назад)

Imports System,Console

Module Module1

    Sub Main() 'Раскомментировать нужную (под)программу
        'Fst()
        'Snd()
        'Trd()
        'Foth()
        'Fth()
    End Sub

    Sub Fst()
        Dim a, b, c As Double
        b = 8.45
        a = Double.Parse(ReadLine())
        c = Double.Parse(ReadLine())
        WriteLine("y({0}, {1}) = {2}", a, c, Math.Sin(a) : 2 - b * Math.Acos(c) + Math.E : (-3.4 * a) + 2 * Math.Log(Math.Abs(a - c)))
        ReadKey(False)
    End Sub

    Sub Snd()
        Dim x As Double = Double.Parse(ReadLine())
        WriteLine("y({0}) = {1}", x, Math.E : IIf(x > 2, x, IIf(x < 1, (2 * x), -x)))
        ReadKey(False)
    End Sub

    Sub Trd()
        For x As Double = 5 To 65
            WriteLine("y({0}) = {1}", x, (x / 2) + ((x : 2 + Math.E : (-x)) / 20))
        Next
        ReadKey(False)
    End Sub

    Sub Foth() ' Тут лучше было бы использовать указатели, ну да так проще
        Dim a(10), min As Double
        Dim x As Integer
        For x = 0 To 9
            Write("a({0}) => ", x)
            a(x) = Double.Parse(ReadLine())
        Next
        min = a(0)
        For x = 1 To 9
            If (a(x) < min) Then
                min = a(x)
            End If
        Next
        For x = 0 To 9
            If (a(x) Mod 2 = 1) Then
                a(x) = min
            End If
        Next
        For x = 0 To 9
            WriteLine("a({0}) => {1}", x, a(x))
        Next
        ReadKey(False)
    End Sub

    Sub Fth()
        Dim p, s, a(36) As Double
        p = 1
        For x As Integer = 0 To 35
            Write("a({0}) => ", x)
            a(x) = Double.Parse(ReadLine())
            If (x < 5) Then
                p *= a(x)
            Else
                s += a(x)
            End If
        Next
        WriteLine("p(1..5) = {0}", p)
        WriteLine("s(6..36) = {0}", s)
        WriteLine("p(1..5) / s(6..36) = {0}", p / s)
        ReadKey(False)
    End Sub
End Module







+ 0 -
Vasilii18012000
10 марта 2014 г., 11:48:00 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите составить программу на языке PASCAL

с использованием цикла с предусловием.
2 фото это то что у меня получается,что не так?

Паскаль.

1) В банк положили вклад N рублей. Каждый месяц вклад увеличивается на 1%. Определить размер вклада через 5 лет.
2) Дано натурального число. Найти сумму его делителей, не кратных 3.
3) Дано натурального число. Найти его максимальную цифру.

Оператором сотовой связи называется:

1) совокупность базовых станций, расположенных по принципу сот (ячеек)

2) лицо, пользующееся услугами сотовой связи

3) организация, принимающая оплату услуг сотовой связи

4) организация, обслуживающая средства сотовой связи

5) организация, имеющая лицензию на предоставление услуг сотовой связи и оказывающая эти услуги

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

помогите решить пожалуйста))


Вы находитесь на странице вопроса "помогите решить пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.