Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Дана строка. Посчитать сколько в ней букв «ы», «ю», «я».

10-11 класс

Радость1324225 01 февр. 2017 г., 8:05:27 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vlaaadka
01 февр. 2017 г., 8:59:19 (7 лет назад)

var
  s: string;
  i, n1, n2, n3: integer;

begin
  s := 'Это текст для подсчета в нем символов. Такое вот занятное дело.';
  s := s + 'Выбраны не самые частые буквы - ы, ю, я, но таково задание!';
  n1 := 0; n2 := 0; n3 := 0;
  for i := 1 to length(s) do
    case upcase(s[i]) of
      'Ы': n1 := n1 + 1;
      'Ю': n2 := n2 + 1;
      'Я': n3 := n3 + 1;
    end;
  writeln('В строке встретились буквы: ы :', n1, ' раз, ю :',
    n2, ' раз, я: ', n3, ' раз')
end.

Тестовое решение:

В строке встретились буквы: ы :6 раз, ю :1 раз, я: 3 раз

+ 0 -
Tsaplina02nasty
01 февр. 2017 г., 10:17:28 (7 лет назад)

Комментарий удален

+ 0 -
Nikitapechurin
01 февр. 2017 г., 11:15:27 (7 лет назад)

Pascal ABC

Ответить

Другие вопросы из категории

Visual Basic 1)Укажите допустимые имена: а)Переменная б)G1G2H3 в)Dim г)D&G д)2_значное

е)Нов.значение

ж)qaz wer

2. Определите значение переменных по фрагменту программы с помощью трассировки:

а)Dim a As String, b As String, c As String
a = “У нас ”
b = “3”
с = a & b & “пары”

б)Dim Q1 As Integer, Q2 As Integer
Const Q As Integer = 15
Q1 = 1
Q2 = 2
Q1 = Q + Q2
Q2 = Q1 *Q2

с)Dim a As Byte, b As Byte, c As Byte
a = 3
b = 100
b = b + a
с = a * b

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Дана строка.Определить сколько раз входит в нее группа букв a b c.

Пожалуйста,не надо писать решай сама!



Вы находитесь на странице вопроса "Дана строка. Посчитать сколько в ней букв «ы», «ю», «я».", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.