Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано N-произвольных чисел найти их сумму. Срочно нужно !

5-9 класс

Sashaspilberg555 15 авг. 2016 г., 15:28:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kraev002
15 авг. 2016 г., 17:48:40 (7 лет назад)

Код программы на Pascal :

Program asd;

var n,sum,i,a:integer;

begin

sum:=0;

Write('Введите кол-во чисел');

read(n);

For i:=1 to n do 

 begin

  Write('Введите число');

   read(a);

    sum:=sum+a;

end;

Writeln('Сумма равна',sum);

readln;

end.

Ответить

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.



Вы находитесь на странице вопроса "Дано N-произвольных чисел найти их сумму. Срочно нужно !", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.