Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите пожалуйста сделать домашнее задание в паскале, экселе и блок-схему! (задание для продвинутых пользователей)

10-11 класс

(более подробно на фото л.р.9)
Диаметр горловины водоструйного элеватора в системах водяного отопления вычисляют по формуле d=1,55G^0,5/P^0,25 (см). Здесь G-расход теплоносителя в системе отопления после элеваторного узла, который определяется по формуле G=0,86*10^(-3)*(Q/(t1-t0), т/ч; Q-мощность отопительной установки здания, Вт, принять от 100000Вт до 300000вт с шагом 20000вт, t1-температура в падающей магистрали системы отопления, применять 105; t0-температура в обратной магистрали системы отопления, принять 70; P-расчетное давление в системе отопления для циркуляции теплоносителя, кПа, принять Р=12кПа. Определение записать в виде функции.

Юрий1995 11 февр. 2014 г., 11:30:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ritapavlovna
11 февр. 2014 г., 13:12:52 (10 лет назад)

function d(P, Q, t, t0: real): real;
var
  G: real;

begin
  G := 0.86e-3 * Q / (t - t0);
  d := 1.55 * sqrt(G) / sqrt(sqrt(P))
end;

var
  Q, t, t0, P, q1, q2, h: real;

begin
  q1 := 1e5; q2 := 3e5; h := 2e4;
  t := 105; t0 := 70; P := 12;
  Q := q1;
  while Q <= q2 do
  begin
    Writeln('Qзд=', Q:0:0, ', d:=', d(P, Q, t, t0):0:3);
    Q := Q + h
  end
end.

Тестовое решение:

Qзд=100000, d:=1.305
Qзд=120000, d:=1.430
Qзд=140000, d:=1.545
Qзд=160000, d:=1.651
Qзд=180000, d:=1.751
Qзд=200000, d:=1.846
Qзд=220000, d:=1.936
Qзд=240000, d:=2.022
Qзд=260000, d:=2.105
Qзд=280000, d:=2.184
Qзд=300000, d:=2.261


+ 0 -
Berseneza
11 февр. 2014 г., 13:47:05 (10 лет назад)

В Экселе тоже процедуру делать? А вы учили макросы и VBA?

Ответить

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)



Вы находитесь на странице вопроса "Помогите пожалуйста сделать домашнее задание в паскале, экселе и блок-схему! (задание для продвинутых пользователей)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.