Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Дано

10-11 класс

число k (0 < k < 11) и матрица размера 4 x 10. Найти сумму и произведение
элементов k-го столбца данной матрицы.

Serega282 22 мая 2014 г., 18:37:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
As82
22 мая 2014 г., 20:29:56 (9 лет назад)

var
j,i,k,sum,proizv: integer;
A: array [1..4,1..10] of integer;
begin
proizv:=1;
randomize;
writeln('Матрица: ');
for i:=1 to 4 do
 for j:=1 to 10 do
  A[i,j]:=random(21)-10;
for i:=1 to 4 do
 begin
 for j:=1 to 10 do
  write(A[i,j]:5);
  writeln;
  writeln;
 end;
writeln('Введите К: ');
read(k);
for i:=1 to 4 do
 begin
 sum:=sum+A[i,k];
 proizv:=proizv*A[i,k];
 end;
writeln('Cумма чисел ',k,'-ого столбца: ',sum);
writeln('Произведение чисел ',k,'-ого столбца: ',proizv);  
end.

Ответить

Другие вопросы из категории

восстановии цепочку чисел 42 45 49 ...94
Помогите пожалуйста решить задачу в Excel.

В небольшом предприятии его сотрудникам выдаётся месячная зарплата. Кассир, имея на руках бухгалтерскую ведомость, собирается ехать в банк за деньгами. При этом он имеет возможность не просто подать заявку на общую сумму, а указать в ней также, какими именно купюрами ему хотелось бы получить её. Делается это для того, чтобы потом было удобнее рассчитываться с каждым отдельным работником (например, если выплаты производится, как говорят, «в конвертах»). Предварительно все исходные данные нужно представить в виде таблицы, где против каждой фамилии сотрудника, как только вводится начисленная ему зарплата, она тут же выражается соответствующим набором денежных знаков. Одновременно подводится и общий итог по всему коллективу для формирования банковского заказа. При определении набора следовать принципу наименьшего числа купюрРади упрощения задачи расчёт вести только на бумажные деньги с точностью до 10 рублей
Для расчётов использовать встроенные функции ЦЕЛОЕ и ОСТАТ из категории «математических» .

Задача

Сколько килобайт
будет занимать файл в простом текстовом формате, если в тексте 300 страниц, на
странице 25 строк, а в строке в среднем 45 символов?



Задача




В
каталоге находится 6 файлов:

Читайте также

Данные, объемом 16 Мбайт, поступают на компьютер по линии со скоростью передачи данных 32 Мбит/с. После получения 4 Мбайт компьютер начинает одновременно

передавать эти данные по другой линии связи со скоростью 4 Мбит/с. Сколько секунд пройдет от начала приема данных по высокоскоростному каналу до полной передачи их по низкоскоростному каналу?

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "Дано", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.