Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Паскаль

10-11 класс

Найти произведение двух средних цифр четырехзначного числа.

ShaDo123 13 июня 2016 г., 1:28:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Warter00
13 июня 2016 г., 3:13:16 (7 лет назад)

var
  number, first, second : integer; //Число, первая цифра, вторая цифра
begin
  write('Число: ');
  readln(number);
  
  second := number mod 100 div 10;
  first := number div 100 mod 10;
  writeln('Произведение: ', first * second);
end.

Ответить

Другие вопросы из категории

Где хранятся сведения об адресатах? (Outlook Express)

• в папке Входящие
• в адресной книге
• в папке Черновики
• в блокноте

100 балов. Написать программу для решения линейного уравнение у = Ах^2 + Вх.

Вычислить корни линейного уравнения,должна быть проверка на
неравенство коэффициента A к нулю.
Язык с++, можно и паскаль.

Сформировать массив из 15 произвольных чисел. Поменять местами элементы, стоящие на нечетных местах, с соответствующими элементами, стоящими на четных м

естах. Полученный массив вывести на экран.
Нужна прога для Паскаль АВС
Спасибо!

В некоторой стране автомобильный номер длиной 7 символов составляют из заглавных букв (задействовано 23 различных букв) и десятичных цифр в любом пор

ядке. Каждый такой номер в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит). Определите объем памяти, отводимый этой программой для записи 50 номеров.Желательно подробное решение

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.