Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Введите случайным образом 10 массивов от 1 до 5 и найдите их сумму. Выведите на экран полученное число

5-9 класс

помогите ,пожалуйста !

Makario 13 июля 2014 г., 12:43:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
UrZaNa
13 июля 2014 г., 14:42:42 (9 лет назад)

Я слишком мало спал поэтому туплю, но насколько я понял что-то типа этого
var
x,i:integer;
a0,a1,a2,a3,a4,a5,a6,a7,a8,a9:array [1..5] of integer;
begin
for i:= 1 to 5 do
a0[i]:=random(5)+1;
for i:= 1 to 5 do
a1[i]:=random(5)+1;
for i:= 1 to 5 do
a2[i]:=random(5)+1;
for i:= 1 to 5 do
a3[i]:=random(5)+1;
for i:= 1 to 5 do
a4[i]:=random(5)+1;
for i:= 1 to 5 do
a5[i]:=random(5)+1;
for i:= 1 to 5 do
a6[i]:=random(5)+1;
for i:= 1 to 5 do
a7[i]:=random(5)+1;
for i:= 1 to 5 do
a8[i]:=random(5)+1;
for i:= 1 to 5 do
a9[i]:=random(5)+1;
for i:=1 to 5 do
x:=x+a0[i];
for i:=1 to 5 do
x:=x+a1[i];
for i:=1 to 5 do
x:=x+a2[i];
for i:=1 to 5 do
x:=x+a3[i];
for i:=1 to 5 do
x:=x+a4[i];
for i:=1 to 5 do
x:=x+a5[i];
for i:=1 to 5 do
x:=x+a6[i];
for i:=1 to 5 do
x:=x+a7[i];
for i:=1 to 5 do
x:=x+a8[i];
for i:=1 to 5 do
x:=x+a9[i];
writeln(x);
end.

Ответить

Другие вопросы из категории

помогите пожалуйста

Работая в колхозном саду, школьники собрали 28 ящика фруктов; в одних были яблоки, в других – груши, в третьих – сливы. Можно ли утверждать, что имеется, по крайней мере, 9 ящиков с одним из указанных видов фруктов? Какое максимальное и минимальное количество ящиков с фруктами одного вида может быть?

Читайте также

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

выведите на экран числа от 100 до 200

вывести на экран квадраты и кубы в диапазоне от -10 до +10
используя repeat



Вы находитесь на странице вопроса "Введите случайным образом 10 массивов от 1 до 5 и найдите их сумму. Выведите на экран полученное число", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.