Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Cтроки. Паскаль. 1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному

10-11 класс

( символы записываются в обратной последовательности.)

2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Innusik96 11 янв. 2015 г., 10:20:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
8525
11 янв. 2015 г., 11:59:41 (9 лет назад)

{Первая задача}
var
  s, rez: string;  // строки
  i: integer;  // целое число (счетчик)

begin
  writeln('Введите строку:');
  readln(s);  //
  for i := length(s) downto 1 do  // просматриваем буквы, начиная с последней
    rez := rez + s[i];  // прибавляем букву к результату
  writeln(rez)  // выводим результат
end.

Ответить

Другие вопросы из категории

Исполнитель кузнечик живёт на числовой оси. Кузнечик умеет выполнять команды: "вперёд N" (кузнечик прыгает вперёд на N единиц), назад М (кузнечик

прыгает назад на М единиц). Передвижения N и М могут принимать любые целые положительные значения. Известно, что кузнечик (?выполняя?) программу из 70 команд, в которой команд "назад 2" на 20 больше, чем команд "вперёд 3". Других команд в программе не было. На какую одну команду можно заменить эту программу, чтобы кузнечик оказался в той же точке, что и после выполнения программы.

Читайте также

Дана последовательность, содержащая от 2 до 30 слов, в каждом из от 1 до 8 символов строчных латинских букв между соседними словами-не менее одного

пробела, за последним словом-точка. Составить программу на языке Паскаль
1) Все слова, которые встречаются в последовательность по одному разу

Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов

символов, в которых также могут встречаться следующие символы:
Символ «?» (вопросительный знак) означает ровно один произвольный символ.
Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность.
Определите, какое из указанных имен файлов удовлетворяет маске: ?hel*lo.c?*.
А). hello.c
Б) hello.cpp
В) hhelolo.cpp
Г) hhelolo.c

Написать программу для нахождения суммы цифр, составляющих число произвольной длины.Написать программу, позволяющую определить, сколько заданных символов

в данной фразе (искомые символы и фраза вводятся с клавиатуры. Например, сколько букв А и а в слове АбракАдабрА)

Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в

именах файлов символов, в которых также могут встречаться следующие символы:
Символ «?» (вопросительный знак) означает ровно один произвольный символ.
Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность.



Вы находитесь на странице вопроса "Cтроки. Паскаль. 1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.