Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПАСКАЛЬ АВС

10-11 класс

ОЧЕНЬ СРОЧНО,ПОЖАЛУЙСТА


При помощи функции trunc() в Паскале можно реализовать операции целочисленного деления и взятия остатка от деления. Например:
целочисленное деление - trunc(491/240) - результатом будет 2;
остаток от деления - 491-240*trunc(491/240) - результатом будет 11.
Используя функцию trunc(), напишите программу, считающую сдачу в английской денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам). Напишите программу, в которой в трёх константах хранится стоимость товара. Одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). Ещё в трёх таких же константах хранится плата покупателя. Используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. НЕ ИСПОЛЬЗОВАТЬ УСЛОВНЫЙ ОПЕРАТОР

ПРОГРАММА ДОЛЖНА БЫТЬ НАПИСАНА НА ПАСКАЛЕ АВС

Аделинка2324 27 февр. 2015 г., 4:12:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Белло4ка
27 февр. 2015 г., 6:52:57 (9 лет назад)

В одном фунте 20*12=240 пенсов.
Стоимость товара: F1 - фунты, S1 - шиллинги, P1 - пенсы
Плата покупателя: F2 - фунты, S2 - шиллинги, Р2 - пенсы
Х - сдача в пенсах

const
  f1=11;
  s1=5;
  p1=3;
  f2=12;
  s2=10;
  p2=0;
var
   x:integer;
begin 
x:=f2*240+s2*12+p2-f1*240-s1*12-p1; 
writeln('Сдача:'); 
writeln('фунтов ',trunc(x/240)); 
x:=x-240*trunc(x/240); 
writeln('шиллингов ',trunc(x/12)); 
x:=x-12*trunc(x/12); 
writeln('пенсов ',x);
end.

+ 0 -
Nika556
27 февр. 2015 г., 8:32:59 (9 лет назад)

Ну обычно, цена и плата вводятся с клавы во время выполнения задания. Если в задании написано через константы делать, сделаем через них, просто первый раз такое требование слышу. Ну, если что, потом переделаем

+ 0 -
Melkovakk
27 февр. 2015 г., 10:03:31 (9 лет назад)

Точно,я только начала разбираться с программированием (быстрый курс так сказать) и очень трудно,так как почти ничего не знаю :(

+ 0 -
Maga203
27 февр. 2015 г., 12:35:33 (9 лет назад)

Вот, сделал. Числа в разделе констант взяты наобум. Их можно менять на другие.

+ 0 -
Ilyagshsb
27 февр. 2015 г., 14:29:26 (9 лет назад)

Спасибо большое,сейчас буду разбираться ,дабы все понятно )

+ 0 -
Emil110
27 февр. 2015 г., 16:00:37 (9 лет назад)

все понять *

Ответить

Другие вопросы из категории

Cтроки. Паскаль. 1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному

( символы записываются в обратной последовательности.)

2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Читайте также

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.

Известно число жителей, проживающих в каждом доме

улицы. Нумерация домов проведена подряд. Дома с нечетными номерами
расположены на одной стороне улицы, с четными — на другой. На какой
стороне улицы проживает больше жителей? В ПАСКАЛЕ АВС



Вы находитесь на странице вопроса "ПАСКАЛЬ АВС", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.