Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ввести целое число. Затем ввести 1 цифру (0-9) и проверить если эта цифра в числе.

5-9 класс

C++

Annaelbek 21 июля 2013 г., 7:22:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Unna
21 июля 2013 г., 7:53:52 (10 лет назад)

#include <iostream>
#include <stdlib.h>
using namespace std;

int main(){
    long n,p;
    char s[34],c[34];
    cout<<"Vvedite chislo ";
    cin>>n;
    cout<<"Vvedite tsifru ";
    cin>>p;
    ltoa(n,s,10); ltoa(p,c,10);
    if (strchr(s,c[0])==NULL)
        cout<<"Net takoy tsifry";
    else
        cout<<"Takaya tsifra est'";
    return 0;
}

Ответить

Другие вопросы из категории

1. Дан двухмерный массив A(n,m).

Найти произведение отрицательных четных элементов второго столбца массива.

2. Дан двухмерный массив m*n.
Получите одномерный массив b, элементы которого равны min элементам по строкам.

история развития ЭВМ (-)
Для шифровки каждой буквы слова используется двузначное число.Известтно,что буква "к" кодируется числом 15.Среди слов "торт","ежик","станок","беседа" ес

ть слова,кодируемые последовательностями цифр: 35291815, 303113241115.

Какая последовательность цифр является кодом слова "китёнок"?

1,3 задание

Плиииииз, срочно надо

решите быстренько пожалуйста

Читайте также

Пожалуйста решите, буду благодарна))))) Действие компьютерного вируса состоит в том, что вместо букв «б», «в», «л», «о», «т» печатаются цифры, кроме циф

- ры 0, причём разным буквам соответствуют разные цифры. Выясните, какие цифры каким буквам соответствуют, если известно, что: 1) сумма цифр слова «бот» равна 8; 2) сумма цифр слова «вол» равна 9; 3) сумма цифр слова «болт» равна 11; 4) сумма цифр слова «лото» равна 12.

Помогите, пожалуйста, если можно подробно.

Действие компьютерного вируса состоит в том, что вместо букв "б", "в", "л", "о", "т" печатаются цифры, кроме цифры 0, причем разным буквам соответствующие разные цифры.
Выясните какие цифры каким буквам соответствуют, если известно, что:
1) сумма цифр слова "бот" равна 8;
2) сумма цифр слова "вол" равна 9;
3) сумма цифр слова "болт" равна 11;
4) сумма цифр слова "лото" равна 12.

Действие компьютерного вируса состоит в том, что вместо

букв «б», «в», «л», «о», «т» выводятся цифры, кроме цифры

0, причём разным буквам соответствуют разные цифры.

Выясните, какие цифры каким буквам соответствуют, если

известно, что:

1) сумма цифр слова «бот» равна 8;

2) сумма цифр слова «вол» равна 9;

3) сумма цифр слова «болт» равна 11;

4) сумма цифр слова «лото» равна 12.

1) Компьютерный вирус А заполняет 1 ГБАЙТ за 1 месяц, вирус В за 2 месяца , вирус С , за 3 месяца , а вирус D за шесть месяцев. На компьютере установлены

все 4 вируса. Сколько ГИГАБАЙТОВ они заполнят за 1 месяц.
2) Действие компьютерного вируса состоит в том, что вместо букв "б", "в", "л", "о", "т". выводятся цифры кроме цифры 0, причем разным буквам соответствуют разные цифры. Выясните,какие цифры каким буквам соответствуют, если известно что :
1)сумма цифр слова "бот" равна 8 ;
2) сумма цифр слова "вол" равна 9;
3)сумма цифр слова "болт " равна 11
4)сумма цифр слова лото равна 12

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2



Вы находитесь на странице вопроса "Ввести целое число. Затем ввести 1 цифру (0-9) и проверить если эта цифра в числе.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.