Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Написать программу, которая запрашивает у пользователя номер товара и выводит его название (не менее 5 товаров). Если пользователь указывает недопустимое

10-11 класс

число, то выво-дится сообщение «Ошибка ввода данных»

Nikitos89099 03 мая 2014 г., 3:03:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Артемkst
03 мая 2014 г., 4:52:53 (9 лет назад)


type goods = record  name:String;  price:real;  end;const GOODS_COUNT = 5;var goodsList:array[1..GOODS_COUNT] of goods;id:integer;begin  goodsList[1].name:='iPhone 5s';  goodsList[1].price:=760.0;  goodsList[2].name:='Samsung Galaxy s5';  goodsList[2].price:=540.0;  goodsList[3].name:='Simens m60';  goodsList[3].price:=12.5;  goodsList[4].name:='HTC ONE X';  goodsList[4].price:=450.5;  goodsList[5].name:='LG L9';  goodsList[5].price:=600.0;    write('Write goods id:');  readln(id);  if ( ( id < 0 ) or ( id > GOODS_COUNT ) ) then    writeln('WRONG ID')  else    writeln(goodsList[id].name,' price =',goodsList[id].price);    end.

Ответить

Другие вопросы из категории

Какое наименьшее число

символов должно быть в алфавите, чтобы
при помощи всевозможных трехбуквенных
слов, состоящих из символов данного
алфавита, можно было передать не меньше
9 различных сообщений?

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

Здравствуйте! Помогите решить задания! Не понимаю программу Кумир, к сожалению, завтра последняя возможность исправить оценку. заранее

спасибо

1. Напечатать числовой ряд: 1,7,13,19,25,31,……….61 с помощью цикла «пока».

2. Написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «Нужно продолжить работу?», и пользователь отвечаетда/нет. Программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше.

3. Дан массив из 10-ти чётных натуральных чисел – от 2 до 20.

А) Найдите сумму элементов массива.

Б) Найдите минимальный элемент массива.

4. Дан массив из 15 подряд идущих натуральных чисел, начиная с 50.

А) Найдите произведение элементов массива.

Б) Найдите максимальный элемент массива.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "Написать программу, которая запрашивает у пользователя номер товара и выводит его название (не менее 5 товаров). Если пользователь указывает недопустимое", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.