Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найдите первое четное значение массива задан массив случайных чисел 29 61 38 21 46 67 9 35 68 85 четные элементы массива 28 38 46 68 первое четное 28

5-9 класс

Artyr2112 01 апр. 2015 г., 2:11:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
D005ag
01 апр. 2015 г., 4:10:27 (9 лет назад)

Как я понял, вы опечатались и первый элемент равен 28?
var a:array[1..10] of integer; i,f,k: integer;
begin
f:=0; k:=0; i:=1;
a[1]:=28;a[2]:=61;a[3]:=38;a[4]:=21;a[5]:=46;
a[6]:=67;a[7]:=9;a[8]:=35;a[9]:=68;a[10]:=85;
while k<>1 do begin
if a[i] mod 2=0 then begin k:=1; f:=a[i]; end;
i:=i+1;
end;
writeln('Первый четный элемент массива ',f);
readln
end.
Пишите, если что не так.

+ 0 -
Uliya1703
01 апр. 2015 г., 5:56:30 (9 лет назад)

да, вроде

+ 0 -
Archibald7
01 апр. 2015 г., 7:37:35 (9 лет назад)

Да!

Ответить

Другие вопросы из категории

1. Известно, что Саша старше Оли,но младше Пети. Вася старше Саши и Коли. Оля - не самая младшая, а Вася - не самый старший из ребят. Расположите имена

ребят по их возрасту в порядке возрастания.

2. В соревнованиях по плаванию участвовали Андрей, Виктор, Саша и Дима. Их друзья высказали предположения о возможных победителях:
1) первым будет Саша, Виктор будет вторым,
2) вторым будет Саша, Дима будет третьим,
3) Андрей будет вторым, Дима будет четвертым.
По окончании соревнований оказалось, что в каждом из предположений только одно из высказываний истинно, другое - ложно.
Какое место на соревнованиях занял каждый из юношей.

3. Виновник ночного дорожно-транспортного происшествия скрылся с места аварии.
Первый из опрошенных свидетелей сказал, что это были Жигули, первая цифра машины - единица.
Второй свидетель заявил сказал, что машина была Москвич, а номер начинался с семерки.
Третий свидетель заявил, что машина была иностранная, номер начинался не с единицы.
Оказалось, что каждый из свидетелей правильно указал либо марку, либо первую цифру номера. Какой машина была марки и с какой цифры начинался номер?

автомат-исполнитель число:3456
Как решать задачи по информатике 7 класс Вождь племени Мульти поручил своему министерству разобрать довоичный код и пересевти в него всю важную

информацию.Двоичный код какой разрядности потребуется, если алфавит, используемый племенем Мульти, содержит 16 символов?

Читайте также

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

Глупая надежда спрашивать решение..но все же.. 1.Создать массив на 20 значений. 2.Загрузить массив случайными числами от 10 до 100.Как

выразился мой учитель это подсказка: P=INT(RND*90+10)

3.Выполнить сортировку массива по возрастанию.

4.Вывести значение массива в столбик на экран.

Пожалуйста помогите..сегодня весь класс двойки получил...

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.



Вы находитесь на странице вопроса "найдите первое четное значение массива задан массив случайных чисел 29 61 38 21 46 67 9 35 68 85 четные элементы массива 28 38 46 68 первое четное 28", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.