Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

помогите пожалуйста

10-11 класс

Даны 3 числа a,b,c. Определить минимальное из них. Если минимальное число окажется отрицательным , то определить количество отрицательных чисел , а иначе все положительные числа заменить на отрицательные .
Написать программу и блок схему

242013 08 апр. 2016 г., 7:49:53 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Servisgs
08 апр. 2016 г., 10:47:34 (7 лет назад)

program project1;
uses
crt,math;
var  s:real;  i,j,f:real;  a:integer;
begin 
writeln('vvedite 1 chislo ');readln(i);
  writeln('vvedite 2 chislo ');readln(j); 
 writeln('vvedite 3 chislo ');readln(f); 
 s:=i; 
 if j<s then s:=j; 
 if f<s then s:=f;
 if s<0 then 
 begin  
  if i<0 then inc(a);  
  if j<0 then inc(a);  
  if f<0 then inc(a);  
  writeln('kolichestvo otricatelnix ',a:2);
  end 
 else  
begin  
  if i>0 then i:=i*-1;
  if j>0 then j:=i*-1;
  if f>0 then f:=i*-1; 
 end; 
 writeln('min chislo ',s:2:0); 
 readln;
end.     

Ответить

Другие вопросы из категории

Какие темы можно взять для создания сайта?

Только не одну пожалуйста

совокупность компьютерных программ называют?

а) информационными средствами информатизации
б) аппаратными средствами информатизации
в) программными средствами информатизации
г) все варианты ответа

Задать ячейкам A2, B2, C2 имена и, v, w. В ячейках содержится числа. Ввести в ячейки A3, A4 и т.д. логические формулы, которые возвращают значение ИСТИНА

тогда и только тогда, когда:
а)каждое из чисел и, v, w является положительным.
б)хотя бы одно из чисел и, v, w является положительным.
в)только одно из чисел и, v, w является положительным.
г)не одно из чисел и, v, w не является положительным.
д)хотя бы одно из чисел и, v, w не является положительным.
Какие формулы вводить?

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.