Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Напишите программу( в паскале авс), которая находит НОК (наименьшее общее кратное) двух чисел, введённых с клавиатуры.

5-9 класс

Semek 23 июня 2013 г., 1:49:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
коте23092002
23 июня 2013 г., 4:15:07 (10 лет назад)

Для решения этой задачи воспользуемся формулой:
а*б=НОД(а,б)*НОК(а,б)
var a,b:longint;
function nod(a,b:longint):longint;
begin
if a= 0 then
nod:=b else
if b=0 then
nod:=a else
if a>b then
nod:=nod(a mod b,b) else
nod:=nod(a,b mod a);
end;
Begin
read(a,b);
writeln((a*b) div nod(a,b));
End.

Ответить

Другие вопросы из категории

пять букв английского алфавита закодированы кодами различной длины

М(000) N(11) O(01) p(001) R(10)
определите какой набор букв закодирован двоичной строкой 011001100001001.
1)ORPMRO 2)ORORPP 3)ORPRPP 4)RORRMRO

что воспренимает человек, собака, робот, муравей.

есть звук, вкус, свет, запах.

на координатной плоскости отметьте и пронумеруйте точки со следующими

координатами:A(2,5),B(6,5),C(11,7,)D(11,4),E(6,2),F(2,2),G(4,8),H(9,9),I(3,2),J(3,4),K(5,4),L(5,2).соедините точки:a-b-c-d-e-f-a-g-h-c.g-b-e.i-j-k-l.

Читайте также

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

Напишите программу для паскаль авс

Задачи:
1.Ввести три целых числа, найти максимальное из них
2.Ввести пять целых чисел, найти максимальное из них



Вы находитесь на странице вопроса "Напишите программу( в паскале авс), которая находит НОК (наименьшее общее кратное) двух чисел, введённых с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.