Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1) Нужно найти самое длинное слово в строке считая знаком их разделения пробел.

5-9 класс

2) Составьте программу которая определяет количество буквы "а
" в заданном тексте.
3) Замените запятыми пробелы между словами заданного текста.

ПАСКАЛЬ

Хорошистра 24 апр. 2013 г., 16:58:43 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Larisazubko201
24 апр. 2013 г., 19:33:23 (11 лет назад)

Могу на VBA Excel
Код программы практически как в Паскале.
Саму программу можно увидеть нажав Alt+F11

Ответить

Другие вопросы из категории

СРОЧНО ПОМОГИТЕ С ЛОГИЧЕСКОЙ ЗАДАЧЕЙ ПО ИНФОРМАТИКЕ, СРОЧНО ПОЖАЛУЙСТА...

"шестеро друзей в ожидании электрички заскочили в буфет в котором:
1)Маша купила себе тоже самое, что и Егор
2)Аня купила тоже, что Саша, но не стала покупать шоколадные печенье
3)Кирилл ел то же, что и Наташа,но кроме луковых чипов
4)Егора ел тоже, что и Наташа, но в место бутеров с котлетки предпочел картоф чипы
5)Саша ела тоже, что и Наташа, но вместо молочного коктейля, купила лимонад
Из чего состоялся завтрак каждого?

Помогите решить задачу по информатике в паскале!

Программа определения цифры десятков натурального числа

Какие современные устройства не поддерживают подключение через разъём локальной сети?

а) Принтер
б) Проектор
в) Smart TV
г) Клавиатура

Читайте также

Помогите кто чем может!) НУжно составить программу на языке QBasic. Суть задания: 1)Ввести совю фамилию, имя, отчество как одно текстовое

данное.

а)Определит ьдлину текста.

б)Определить количество букв "b" в нем.

в)Вывести самое длинное слово.

2)Дано предложение. Найти, в каком из слов, состоящего из более чем четырех символов, буква "а" встречается чаще.

По большей части интересует задание 1-в и 2. Буду очень благодарен!!!

помогите, пожалуйста!

дана строка, содержащая текст. найти длину самого короткого и самого длинного слов.

Одной из задач, возникающей при разработке поисковых систем, является поиск самых популярных сайтов по ключевым словам (тегам), описывающим сайт. Дан

список сайтов. Про каждый сайт известны набор тегов сайта и его популярность. Есть запрос в виде набора тегов. На запрос необходимо выдать самый популярный сайт, у которого в описании встречаются все теги из запроса.
Формат входного файла

В первой строке входного файла input.txt находится набор тегов, разделённых ровно одним пробелом, количество тегов не превосходит 5. Тегом назовём такую строку, которая содержит только строчные латинские буквы и ее длина не превосходит 10 символов. В следующей строке дано число N (1 ≤ N ≤ 20)— количество сайтов.

Каждый сайт описывается тремя строками. В первой строке название сайта. Название сайта состоит только из строчных латинских букв и точки. Длина названия сайта не превосходит 15 символов. Во второй строке набор тегов сайта, разделенных пробелами. Количество тегов не превосходит 10. В третьей строке число Ai(1 ≤ Ai ≤ 1000000)— популярность сайта.
Формат выходного файла

В выходной файл output.txt требуется вывести любой самый популярный сайт, у которых встречаются все теги из запроса. Гарантируется, что найдётся, хотя бы один сайт отвечающий запросу.
Пример входных и выходных данных

Input.txt
football volleyball
5
sportbox.ru
sport football volleyball basketball swimming hockey
5000
championat.com
sport football volleyball basketball hockey
4000
soccer.ru
sport football
6000
sport.ru
sport football vоlleyball
1000
sports.ru
sport football volleyball basketball swimming hockey
2000

Output.txt

sportbox.ru

Я задачу решила, на мои тесты работает.

Однако, когда я отправляю ее тестировать на сайт, вылезает что программа выдала неправильный ответ.

program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
s,r:string;
tegs,sait,d,x1:array[1..255] of string;
pop,l,x:array[1..100000] of integer;
i,j,k,n,f,max,max1:integer;
begin
assign(input,'Input.txt');reset(input);
assign(output,'Output.txt');rewrite(output);
readln(s);s:=s+' ';f:=0;
for i:= 1 to length(s) do begin
if s[i]<>' ' then r:=r+s[i];
if s[i]=' ' then begin k:=k+1;d[k]:=r;r:='';end;
end;
readln(n);
for i:= 1 to n do begin
readln(sait[i]);
readln(tegs[i]);
readln(pop[i]);
end;
for i:= 1 to n do begin
for j:= 1 to k do begin
if pos(d[j],tegs[i])<>0 then f:=f+1;
end;
l[i]:=f;
f:=0;
end;
max:=0;max1:=0;
f:=0;
for i:=1 to n do
if l[i]>max then max:=l[i];
for i:=1 to n do
if l[i]=max then begin inc(f);x[f]:=pop[i];x1[f]:=sait[i];end;
for i:=1 to f do
if x[i]>max1 then begin max:=x[i];k:=i;end;
writeln(x1[k]);
close(input);close(output);
end.

Помогите с Паскалем срочно, хорошо оценю 1. Найти S заштрихованной части фигуры. Параметры a, b, c, d, e, f, R вводятся с клавиатуры. 2.

Найти значение y. y={√5x^4 +6 , если x>10 {2x^2 + 3x/ |3x – 8| , если x ≤ 10 (тут эти два выражения под одной системой)!!!

3. В одномерном массиве из 20 элементов, который заполнен случайными числами из диапазона [-20,40], найти среднее между min и max значениями.

4. Найти самое длинное из 3 введённых предложений (известно, что вводятся предложения разной длины).

Помогите!

Нужно написать программу в Паскале.
Нужно найти мах и мин в массиве и поменять их местами!



Вы находитесь на странице вопроса "1) Нужно найти самое длинное слово в строке считая знаком их разделения пробел.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.