Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

10-11 класс

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Zaya14031 12 мая 2013 г., 0:59:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Another125
12 мая 2013 г., 3:25:20 (10 лет назад)

var
  a,b,h,x,y:real;
begin
  writeln('Введите начальное значение, шаг, конечное значение');
  readln(a,h,b);
  x:=a;
  while x<=b do begin
    y:=0.5/tan(x/4)+4;
    writeln(x:7:3,y:10:5);
    x:=x+h
  end
end.

Тестовое решение:

Введите начальное значение, шаг, конечное значение
-5 0.5 5
 -5.000   3.83386
 -4.500   3.76106
 -4.000   3.67895
 -3.500   3.58244
 -3.000   3.46329
 -2.500   3.30698
 -2.000   3.08476
 -1.500   2.72976
 -1.000   2.04184
 -0.500   0.02086
  0.000  Infinity
  0.500   7.97914
  1.000   5.95816
  1.500   5.27024
  2.000   4.91524
  2.500   4.69302
  3.000   4.53671
  3.500   4.41756
  4.000   4.32105
  4.500   4.23894
  5.000   4.16614


+ 0 -
Micha1977
12 мая 2013 г., 4:17:08 (10 лет назад)

Комментарий удален

+ 0 -
Kayak25373
12 мая 2013 г., 5:13:00 (10 лет назад)

+4 отдельно)

Ответить

Читайте также

Помогите пожалуйста составить

программу на ''Pascal ABC'')

Дана строка, содержащая текст на русском языке, и некоторая буква. Подсчитать, сколько слов начинается с указанной буквы.

Составить программу в Pascal

(n+m)*(n+2m)*(n+3m)*...*(n+m^2)
Помогите пожалуйста, срочно!!

Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а)в какой

день он пробежал больше 20 км. б) в какой день суммарный пробег за все дни превысит 100 км? Задача по информатике, надо составить программу в pascal abc. Помогите!

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.



Вы находитесь на странице вопроса "Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.